File System Level corruption of a DVS file causes Enterprise Vault processes terminate unexpectedly with an Event ID 1000 in the application log.

  • Article ID:100009683
  • Modified Date:
  • Product(s):

Problem

When Enterprise Vault (EV) processes attempt to read a DVS file, where file system level corruption has occurred, EV process terminate unexpectedly. 

Error Message

Note: The Event below is an example of what will be seen in the application event log. All portions of the event noted between "<" and ">", such as <Process_Name>, will change depending upon which process is attempting to read the corrupted DVS file.

 
Event: 1000
Source: Application Error 
Category: Application Crashing Events
Description:
Faulting application name: <Process_Name>, version: <Version_Number>, time stamp: <Time_Stamp>
Faulting module name: <Module_Name>, version: <Version_Number>, time stamp: <Time_Stamp>
Exception code: 0xc0000005
Fault offset: <Fault_Offset>
Faulting process id: <Process_ID>
Faulting application start time: <Application_Start_Time>
Faulting application path: (null)
Faulting module path: (null)
Report Id: (null)
 
A dtrace of the process reported as terminating unexpectedly will contain the following text in the last line of the thread attempting to read the corrupt DVS file.
[class CIStreamSequentialStream] Position: 0 hr:0x0

Cause

File system level corruption causes the internal contents of a DVS file to contain unexpected values in the DVS File metadata.

Solution

This issue has been addressed in the following release:

Enterprise Vault 9.0.4 Cumulative Hotfix 5
http://www.veritas.com/docs/000017769

Enterprise Vault 9.0.5 - Release Details
http://www.veritas.com/docs/000088251

Enterprise Vault 10.0.4 - Release Details
http://www.veritas.com/docs/000003643

 

Applies To

EV installations where file system level corruption has occurred

Was this content helpful?

Get Support