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Article: 100028780
Last Published: 2014-04-02
Ratings: 0 0
Product(s): Enterprise Vault
Problem
When launching EV Web Application from http://<evserver>/enterprisevault, the web browser returns the error The Enterprise Vault service is not available.
Error Message
Event ID: 8390
Task Category: Web Application (WP)
Description: The EnterpriseVault.DirectoryConnection object reported an error. Not all privileges referenced are assigned to the caller.
V-437-8390
Cause
If you encounter this message, it could be related to the following reasons.
- The Internet Guest Account either is or has been disabled on EV server.
- The Vault Service Account (VSA) does not have the proper Microsoft Windows Local Security Privileges configured on the EV server.
- The Debug programs or the Log on as a service privilege is not assigned to the VSA.
Solution
Solution 1:
Enable Internet Guest Account on Enterprise Vault server from Local Users and Group:
1. Right click
My Computer, select
Computer Management.
2. From
Local Users and Groups, select
Users.
3. Open properties of
IUSR_Machine_Name (Internet Guest Account), uncheck
Account is disabled.
4. Close Computer Management Console
5. EV services will need to be restarted.
a. This operation can be performed by restarting the EV Admin Service or by rebooting the EV server.
Solution 2:
Confirm the DCOM settings are properly configured for EV.
1. Check that the EV Admin and Directory Services are running.
2. Stop all EV Services, restart the IIS Admin Service and start all EV Services.
3. Check DCOM running status and set the needed DCOM permissions:
a. Log on to the EV Server as the Vault Service Account.
b. Click
Start | Run execute:
dcomcnfg
c. Click
Component Services |
Computers Confirm that DCOM is running
d. Expand
My Computer, expand
DCOM Config
e. Locate
DirectoryService right click and open
Properties.
f. On the
Security tab, click
Edit on the section
Launch and Activation Permissions select
Customize
g. Click over the Group
Everyone andset all permissions as
Allow and remove any permission as
Deny.
h. Add the AD User Account for the VSA and set all permissions as
Allow.
i. Click
OK then
Apply and
OK.
j. Close the
Component Services MMC Console.
4. Reset DCOM permissions:
a. Open the VAC:
Enterprise Vault and right click over
Directory on ... and select
Properties.
b. On the
Service Account tab, delete and reenter the credential details of the VSA.
5. EV services will need to be restarted.
a. This operation can be performed by restarting the EV Admin Service or by rebooting the EV server.
Solution 3:
Check the Microsoft Windows Local Security Policy to determine if the Vault Service Account has the "Debug programs" privilege.
1. Click
Start
|
Programs |
Administrative Tools |
Local Security Policy to launch the Group Policy Editor application on the EV server.
2. Navigate to
Local Policies | User Rights Assignment. Check the
Debug programs privilege to determine if the VSA is listed in the
Security Setting.
3. After the
Debug programs privilege has been restored to the VSA
4. EV services will need to be restarted.
a. This operation can be performed by restarting the EV Admin Service or by rebooting the EV server.