Backup and Duplication jobs to and from an Media Server Deduplication Pool (MSDP) appear to hang or take an extended period of time to complete.

Problem

The NetBackup DeDuplication Manager (spad), which manages the metadata in the mini-catalog, is unable to respond to all requests in a timely manner due to the manner in which the mini-catalog is locked (at a high level) by another request.

Error Message

January 01 21:11:20 INFO [1105971520]: [_handle_find] filter [0|0||-1|-1||*|*|*|*|*|*|*|*|*|-1|-1|-1|-1|-1|-1|-1|-1|-1|-1
January 01 21:11:25 WARNING [1105971520]: 25011: ***WARNING***
severity: warning
server
source: spad
description: [_handle_find] catalog is busy
***DONE***

This error is seen in the spad session logs which are stored in:

   UNIX/Linux: <dedup_path>/log/spoold/<client_hostname>/<calling_process>/spad/MMDDYY.log
             
   Windows: <dedup_path>\log\spoold\<client_hostname>\<calling_process>/spad\MMDDYY.log

 Note: to determine the directory path (dedup_path in the above examples) for MSDP spad/spoold logs, examine the output of 'nbdevconfig -getconfig -storage_server <storageserver_name> -stype PureDisk -configlist file.txt' from ../netbackup/bin/admincmd on the master server, for example:

V7.0 "storagepath" "/Storage" string
V7.0 "spalogpath" "/Storage/log" string
V7.0 "dbpath" "/Storage" string

In the above paths replace <client_hostname> with the name or ip address of the calling system which could be a media server or client. <calling_process> should be replaced with the process on the calling system making the connection to spad - this could be spad, bptm, bpdm or another process.

Cause

The locking on the MSDP mini-catalog is not very granular resulting in some requests being rejected and having to retry multiple times.

Solution

The formal resolution for this issue (Etrack 2987412) is included in the following releases:

  • NetBackup 7.5 Maintenance Release 6 (7.5.0.6)
  • NetBackup Appliances 2.5.3

Both of these releases are now available - please access the Related Article below for more information.

Workaround:
If running NetBackup 7.5.0.5 (or NetBackup Appliances 2.5.2), please contact Symantec technical support, referencing this article and Etrack 3105408 to obtain an Emergency Engineering Binary (EEB) replacement for spad containing a fix for this issue. 

If running a previous version of NetBackup or NetBackup Appliances, an EEB replacement for spad for that version may also be available - please contact Symatnec technical support to determine whether the best course of action is an EEB, or upgrade + EEB.


Applies To

Any NetBackup system utilizing a MSDP disk pool (including NetBackup 52x0 Appliances at version 2.x)

Terms of use for this information are found in Legal Notices.

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