Public folder restores and/or archiving intermittently stop working until EV services are restarted or the server is rebooted

Problem

Public folder restores and/or archiving intermittently stop working until EV services are restarted or the server is rebooted. Errors 3213 and 3211 can be seen in the Windows Enterprise Vault Event log.

Error Message

In the dtrace of the PublicFolderTask process, the following is seen:

 
633 14:16:14.910  [8308] (PublicFolderTask) <11120> EV:L {CMAPISession::CreateMapiSession:#432} Getting IExchangeManageStore object from the privileged mbx
634 14:16:14.910  [8308] (PublicFolderTask) <11120> EV:L {CMAPISession::CreateMapiSession} (Exit) Status: [Success]
635 14:16:14.910  [8308] (PublicFolderTask) <11120> EV:L {CMAPISession::GetMapiSessionFromPoolEx} (Exit) Status: [Success]
636 14:16:14.973  [8308] (PublicFolderTask) <11120> EV:H HrMAPIOpenFolderExKvs - COM error caught 0x80070005
 
 
 
A dtrace of the RetrievalTask during the Outlook manual restore looks as follows:

 
3963 14:26:10.899  [10360] (RetrievalTask) <13972> EV:M CCARestHelper::RMI() - Getting folder properties
3964 14:26:10.899  [10360] (RetrievalTask) <13972> EV:M CCARestHelper::RMI() - Setting restriction to IPM.Note.EnterpriseVault.Shortcut.RestoreMe
3965 14:26:10.899  [10360] (RetrievalTask) <13972> EV:M CCARestHelper::RMI() - Get messages of the folder
3966 14:26:10.899  [10360] (RetrievalTask) <13972> EV:M CCARestHelper::RMI() - Create IExchangeLocation and IExchangeLocation objects
3967 14:26:10.914  [10360] (RetrievalTask) <13972> EV:M CCARestHelper::RMI() - Error [0x80070057]
3968 14:26:10.914  [10360] (RetrievalTask) <13972> EV:M {CMailboxUsage::RemoveUserFromList:#113} Removed [ ] from list of mailboxes being processed. List now contains [0] mailboxes.
3969 14:26:10.914  [10360] (RetrievalTask) <13972> EV:M CAA::RPFI() - Error occurred in public folder:  , by mailbox /O=exchangeorg/OU=users/cn=Recipients/cn=username.  [Attempt: 0, Error: 0x80070057]
3970 14:26:10.914  [10360] (RetrievalTask) <13972> EV:H {CRestorationAgent::RetrievePublicFolderItems()} (Exit) Status: [The parameter is incorrect.  (0x80070057)]
3971 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L {AgentMessageDispenser::ActivateObject:#3502} Acquiring mutex for updating message count...
3972 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L {AgentMessageDispenser::ActivateObject:#3504} Mutex acquired.
3973 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L {AgentMessageDispenser::ActivateObject:#3512} Using Message count value [0].
3974 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L {CFaultInjector::Configure} (Entry)
3975 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L CFaultInjector::LoadConfig looking for fault config in C:\Program Files (x86)\Enterprise Vault\RetrievalTask.EXE.fault.
3976 14:26:10.914  [10360] (RetrievalTask) <13972> EV:H {CFaultInjector::Configure:#124} _com_error exception: [The system cannot find the file specified.  (0x80070002)]
3977 14:26:10.914  [10360] (RetrievalTask) <13972> EV:H {CFaultInjector::Configure} (Exit) Status: [The system cannot find the file specified.  (0x80070002)]
3978 14:26:10.914  [10360] (RetrievalTask) <13972> EV:M {AgentMessageDispenser::ActivateObject:#3808} An error that we don't specifically recognise has occurred, [0x80070057], so we'll just increment this messages retry count.
3979 14:26:10.914  [10360] (RetrievalTask) <13972> EV:L {AgentMessageDispenser::ActivateObject} (Exit) Status: [The dispenser was asked to repost the message to be retried later      (0xc00408e2)]
3980 14:26:10.914  [10360] (RetrievalTask) <13972> EV:M {AgentMessageDispenser::ProcessNextMessage:#1250} It took [0.623933] seconds to process the [MsgID_RetrievePublicFolderItems (55)] MSMQ message body (ActivateObject). Processing the message [failed].

Cause

The following workaround is available for restoring:

  1. Use Archive Explorer to restore the desired item to a user's mailbox (right-click and Copy to Mailbox)
  2. Drag the item from the mailbox back into the Public Folder if necessary.

There is not a workaround for archiving.

Solution

This issue has been addressed in the following releases:


Enterprise Vault 10.0.4
http://www.symantec.com/docs/DOC6317


Enterprise Vault 11.0.0
http://www.symantec.com/docs/DOC7401

 


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)