Imported items with attachments archived in Discovery Accelerator with Exchange 2013 cannot be exported or viewed

Problem

Exchange 2013 messages that contain attachments and are imported into archives using the Enterprise Vault Content Management API (such as third party migration applications) may exhibit the following issues:
 

  • They cannot be exported to PST using Discovery Accelerator
  • They cannot be viewed in Outlook using Archive Explorer

Error Message

The following errors are written to the Symantec Enterprise Vault event log on the Discovery Accelerator server:
 

Log Name: Symantec Enterprise Vault
Source:  Accelerator Service Processor
Event ID: 236
Task Category: None
Level: Error
Keywords: Classic
Description: APP AT - Customer ID: 3 - [ExportPST] - Error moving some messages to PST for run 'ItemAttach (7)' : System.ApplicationException: Error in the application.
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.HooverUpMsgsToPst()
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.ScanProductionItemQueue()
V-437-236
 

Log Name:  Symantec Enterprise Vault
Source:  Accelerator Service Processor
Event ID:  236
Task Category: None
Level: Error
Keywords: Classic
Description: APP AT - Customer ID: 3 - [ExportPST] - Error moving some messages to PST for run 'ItemAttach (7)' : System.ApplicationException: Failed to move some items from 'Failed Items' to 'Messages' folder
   at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.ScanProductionItemQueue()


End users are displayed the following error when viewing items with Archive Explorer:

Could not show this item.
Try again.  If it still fails, contact your Help Desk.

The item could be downloaded. [OIOM] 

End-user error

Cause

Messages with attachments saved from Exchange 2013 as .MSG files have an additional property on the attachment table. The Outlook PST provider cannot handle this property and fails to copy the items into a PST.

Solution

Set the registry value FixExchange2013Attachments to 1:
 

  1. Open regedit the Enterprise Vault Server that contains the Storage Service
     
  2. Navigate to \HKEY_LOCAL_MACHINE\Software\Wow6432Node\KVS\Enterprise Vault\Storage
     
  3. Create DWORD value called FixExchange2013Attachments.
     
  4. Set FixExchange2013Attachments to 1
        Enable = 1
        Disable = 0
     
  5. Restart the Storage service.


Note: Setting the registry value impacts all recalls of Exchange items through the Storage service, adding a small overhead for each item. Therefore you should create the registry value only when you see the above issues in relation to Exchange 2013 items archived via third party applications.  Items archived by the Enterprise Vault archiving tasks or PST Import are not affected by this issue.

 

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)