Archived items are not retrieved using Outlook Web Access when the account is hidden from Exchange Address Lists

Problem

It is possible to configure a user with an exchange mailbox to be hidden from Exchange address lists. The default behavior for EV is to not archive mails from a hidden mailbox but this behavior can be changed by implementing a registry key. The details of this registry key can be found in the related articles section below. When this situation is configured the user is unable to retrieve items in OWA that have been archived by EV. When retrieving an item from an EV shortcut the user is presented with the error shown in the screenshot below.

Error Message

To further confirm that this is the issue being experienced switch on OWA logging as per the article in the related articles section below and check that the following error is generated:

[RestoreRequest::Send] Exception sending request to restore item: System.Net.WebException: The remote server returned an error: (558) ERR Cannot log on.  Incorrect server or mailbox..
at System.Net.HttpWebRequest.GetResponse()
at Symantec.EnterpriseVault.Owa.EVServerRequests.RestoreRequest.Send()
[RequestProcessor::RestoreAndActOnItem] Item not restored

Cause

The issue is caused by the user being hidden from the Exchange address lists. Currently the only way to workaround this issue is to unhide the user from the Exchange Address List by doing the following:

If Exchange 2003 is implemented in the environment the following option is available:

  • Logon to the Exchange 2003 server.
  • Open Active Directory Users And Computers.
  • Search for the relevant user.
  • Double click on the user.
  • Select the Exchange Advanced tab.
  • De-select Hide from Exchange address lists.
  • Click Apply.
  • Test that retrievals are now functional.

If Exchange 2003 is not implemented in the environment:

  • Logon to any Exchange server.
  • Open Exchange Management Console.
  • Search for the relevant user.
  • Double click on the user.
  • On the General tab de-select Hide from Exchange address lists.
  • Click Apply.
  • Test that retrievals are now functional.

Solution

This issue has been addressed as part of the following release:
 

Enterprise Vault 10.0.3 Cumulative Hotfix 2 Release
http://www.symantec.com/docs/TECH205731


Enterprise Vault 10.0.4 - Release Details
http://www.symantec.com/docs/DOC6317


Applies To

Any supported version of Microsoft Exchange Server against any supported version of Enterprise Vault.

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