Putting more than one consecutive question mark wild card fails search

Problem

In Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (CA), putting more than one consecutive question mark wild card in an email address in the To\From field prevents the search from being rejected or the search criteria viewed.

Error Message

From CA or DA Client pop-up error:

Invalid email addresses in the 'From' or 'To' field: john???@mydomain.local. Check that at least three characters are used in front of the wildcard.

From dtrace of the AcceleratorService process:

(RBO_SearchTool2) Exception: Invalid email addresses in the 'From' or 'To' field: john???@mydomain.local.
Check that at least three characters are used in front of the wildcard.
Info:{C2.EN_US} RBO method failed
Diag:
Type:System.Exception
ST:
at KVS.Accelerator.Web.BO.BO_SearchTool2.ParseEmailAddresses(String Emails, Boolean IgnoreError, TargetsAndTargetGroupsDS custodiansCurrentInfo, List`1 custodianIDs, List`1 custodianGroupIDs, TargetsAndTargetGroupsDS& targetsDS, List`1& addresses)|
at KVS.Accelerator.Web.BO.BO_SearchTool2.InitFromDS(SearchCriteriaDS aSearchCriteriaDS)|
at KVS.Accelerator.Web.BO.BO_SearchTool2.GetSearchTemplate(Int32 caseID, Int32 searchID)|
at KVS.Accelerator.RBO.RBO_SearchTool2.GetSearchTemplate(Int32 caseID, Int32 searchID)

Cause

The logic used to process the question mark individual wild card character did not take into account the possibility of 2 or more such wild cards placed together in the 'To', 'From', or 'To of From' fields.

Solution

This issue has been addressed in the following release:


Enterprise Vault 9.0.4 Cumulative Hotfix 5 Release
http://www.symantec.com/docs/TECH205732

Enterprise Vault 10.0.3 - Release Details
http://www.symantec.com/docs/TECH193300

Enterprise Vault 9.0.5 - Release Details
http://www.symantec.com/docs/TECH204715


Applies To

Compliance Accelerator or Discovery Accelerator 8.x, 9.0 through 9.0 SP4, or 10.0 through 10.0 SP2.

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)