GRT enabled backup jobs for a virtual machine completes with exception "Failed to mount one or more virtual disk images".

Problem

GRT enabled backup jobs for a virtual machine completes with exception "Failed to mount one or more virtual disk images".

Error Message

The job has a exception in the job log:   Failed to mount one or more virtual disk images.

Debug from beremote on the media server has the following:

[10868] 2012-10-11T11:53:50.152 [mounter]            - VMDKRemoteImage::mountDisks()  Could not open the mount the volume 0. Error Text: 'Driver not found' Error: '24307'
[10868] 2012-10-11T11:53:50.152 [mounter]            - VMDKRemoteImage::mountDisks()  Could not open the mount the volume 1. Error Text: 'Driver not found' Error: '24307'
[6892] 2012-10-11T11:53:50.152 [fsys\shared]        - VDDK-Log: Vmount library: Error 2 while opening VSTOR2 driver's control device
[6892] 2012-10-11T11:53:50.152 [fsys\shared]        - VDDK-Log: Vmount library: Error 2 while opening VSTOR2 driver's control device
[10868] 2012-10-11T11:53:50.153 [engidrapi]          - CDiskLayoutImplementation::SetAutoMount: Disabling AUTOMOUNT
[10868] 2012-10-11T11:53:50.153 [mounter]            - VDiskMounter::MountAllDisks:failed VirtualSystem::Initialize()
[10868] 2012-10-11T11:53:50.153 [mounter]            - Error mounting disks (0xe0009741)
[10868] 2012-10-11T11:53:50.153 [fsys\ntfs\img_pdi]  + img_pdi_attach.cpp (492):
[10868] 2012-10-11T11:53:50.153 [fsys\ntfs\img_pdi]  | changing VM Guest Computer name from '' to 'Virtual_machine' as the 'x' name is what was used to make the NDMP connection.
[10868] 2012-10-11T11:53:50.153 [fsys\ntfs\img_pdi]  + img_pdi_attach.cpp (581):
[10868] 2012-10-11T11:53:50.153 [fsys\ntfs\img_pdi]  | Error mounting disk(s): E_IMG_FS_FAILED_TO_MOUNT_VIRTUAL_DISK (0xe0009741).
[10868] 2012-10-11T11:53:50.153 [mounter]            - CommonMounter::~CommonMounter called
[10868] 2012-10-11T11:53:50.154 [mounter]            - VMDKRemoteImage::unmountDisks()  Could not dismount the volume 0. Error Text: 'The specified volume is not mounted' Error: '24304'
[10868] 2012-10-11T11:53:50.154 [mounter]            - VMDKRemoteImage::unmountDisks()  Could not dismount the volume 1. Error Text: 'The specified volume is not mounted' Error: '24304'
[5236] 2012-10-11T11:53:50.154 [fsys\shared]        - Calling the vixdiskLib api: VixMntapi_CloseDiskSet()
[5236] 2012-10-11T11:53:50.154 [fsys\shared]        - VDDK-Log: VixDiskLibReaderWriter::Close: Closing disk.
[5236] 2012-10-11T11:53:50.154 [fsys\shared]        - VDDK-Log: VixDiskLibReaderWriter::Close: Closing disk.
[5236] 2012-10-11T11:53:50.156 [fsys\shared]        - Calling the vixdiskLib api: VixDiskLib_EndAccess('10.0.0.221')
[5236] 2012-10-11T11:53:50.156 [fsys\shared]        - VDDK-Log: VixDiskLibVimResolveHostName: Resolving IP address for hostname "ip adress".
[5236] 2012-10-11T11:53:50.156 [fsys\shared]        - VDDK-Log: VixDiskLibVimResolveHostName: Resolved to "ip address".
[5236] 2012-10-11T11:53:50.160 [fsys\shared]        - VDDK-Log: VixDiskLibVim: VixDiskLibVimLogin
[5236] 2012-10-11T11:53:50.410 [fsys\shared]        - VDDK-Warn: HostAgent is not a VirtualCenter, cannot enable sVmotion.
[5236] 2012-10-11T11:53:50.410 [fsys\shared]        - VDDK-Log: VixDiskLibVim: VixDiskLibVimLogout
[10868] 2012-10-11T11:53:50.536 [fsys\shared]        - VixDiskLib_EndAccess() failed. Error code 20. Error Msg: The command is not supported on remote objects
[10868] 2012-10-11T11:53:50.536 [fsys\shared]        - Masking the last error from VixDiskLib_EndAccess().

Cause

VSTOR2 drive is not available or started on the media server causing the failure in mounting disk images.

Solution

1. Check for the existence of <install_path>\system32\DRIVERS\vstor2-mntapi10-shared.sys

2. Run MSinfo32 and see under Software Environment | Signed Drivers if Vstor2 MintApi 1.0 Driver (Shared) is started and running
3. If you find the driver in the Drivers folder, try starting the driver using the following command in the command prompt.

net start vstor2-mntapi10-shared

4. If you do not find the driver in the drivers folder or it fails to start, it will have to reinstalled.
5. Browse to  Backup Exec installation directory: \VMware\VixDiskLib\bin\AMD64 and install the driver using vstor2-mntapi10-shared.inf
6. Check event viewer for confirmation of the installation and then check MSinfo32 to confirm if the driver is started and running.
7. Run backup job again and confirm if the GRT is available.

 

These steps will have to be confirmed on each server.

1. If you do find the driver and it shows \??\c:\windows.... then follow the link to the vmware site to remove the \??\

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2034124

2. After the \??\ has been removed then restart the server and run a backup job.

 


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)