VMware guest machine fails to start up after the restore if SAN on media server is disconnected during backup job.

Problem

An issue was identified with VMware backups that are configured to use the SAN transport mode in Backup Exec 2010 and later. If the SAN is disconnected from the Backup Exec server during a VMware backup job that is configured to use the SAN transport mode, the backup job appears to complete successfully even though no data could be read. No errors are reported. Restore jobs from this backup appear to complete successfully. However, when the guest virtual machine is restored from this backup, the virtual machine fails to start.

 

Error Message

No error is reported, yet the VM (virtual machine) backup or restore operation may have failed.

 

Cause

VMware KB 2010428: VDDK 5.0 does not return error for SAN write to offline LUN
http://kb.vmware.com/kb/2010428

 

As described in this excerpt from the VMware KB article: "VixDiskLib_Read() or VixDiskLib_Write() functions fail to return an error even though they cannot read from or write to an offline or read-only [SAN] LUN."

When operating in the environment described above, SAN reads or writes of the VM can be faulty, yet the backup or restore operation will report success.

 

 

Solution

A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

Backup Exec 2012 Rev 1798 Service Pack 2 (TECH203155)

Backup Exec 2010 Rev 5204 Service Pack 3 (TECH203157)


 


Applies To

Backup Exec 2010 and later
Vmware Agent Option
Backup Jobs using SAN transport mode.
 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)