Hotfix for Symantec Enterprise Vault (EV) 9.0.3 - Users are unable to open Microsoft (MS) SharePoint Enterprise Vault (EV) archived documents with MS Office 2010 using an HTTPS connection.

Problem

Which version of Symantec Enterprise Vault (tm) can this hotfix be applied?
This hotfix can only be applied to the following versions of Enterprise Vault for:

Enterprise Vault for 9.0.3, Build 1164
 

Cause

2850693:
When SharePoint 2010 is configured to use SSL the Enterprise Vault HttpModule does not detect document requests from Office 2010 applications.  Consequently the original item content cannot be accessed by Office 2010 applications when an archived item has been replaced with a shortcut.
 

Solution

What issue(s) does this hotfix resolve?

 

2850693:
The Enterprise Vault HttpModule now correctly detects requests from Office 2010 applications when SharePoint 2010 is configured for SSL.
 

 

Which files does this hotfix replace?

File NameFile VersionNew File Version
KVS.EnterpriseVault.HttpModule.dll9.0.3.11649.0.3.1262

 

 

How to Install this hotfix:
 

On the EV server:

 

1.  Stop the SharePoint archiving task


 

 

On the SharePoint server:

 

1.  Stop the Enterprise Vault Admin Service.

 

2.  Open Windows Explorer and browse to the EV program files folder.

 

3.  Backup the existing copy of KVS.EnterpriseVault.HttpModule.dll to another folder.

 

4.  Copy the KVS.EnterpriseVault.HttpModule.dll file supplied with this hotfix to the EV program files folder.

 

5.  Start an administrative command prompt and navigate to the EV program files folder.

 

6.  Run the following command:

 

gacutil /i KVS.EnterpriseVault.HttpModule.dll

 

Follwed by:

 

iisreset


 

7. Verify that the hotfix version of the Enterprise Vault HttpModule has been installed:

    a.  Open Windows Explorer and browse to the C:\Windows\assembly folder

    b.  Locate the KVS.EnterpriseVault.HttpModule

    c.  Right-click KVS.EnterpriseVault.HttpModule and click Properties

    d.  Select the Version tab and verify that the File version number is 9.0.3.1262

 

8.  Restart the Enterprise Vault Admin Service.


 

 

On the EV server:

 

1. Restart the SharePoint archiving task

 

 

How to Uninstall this hotfix:
 

On the EV server:

 

1.  Stop the SharePoint archiving task


 

 

On the SharePoint server:

 

1.  Stop the Enterprise Vault Admin Service.

 

2.  Open Windows Explorer and browse to the EV program files folder.

 

3.  Replace the hotfix version of KVS.EnterpriseVault.HttpModule.dll with the backed up original version.

 

4.  Start an administrative command prompt and navigate to the EV program files folder.

 

5.  Run the following command:

 

gacutil /i KVS.EnterpriseVault.HttpModule.dll

 

Follwed by:

 

iisreset


 

6. Verify that the hotfix version of the Enterprise Vault HttpModule has been installed:

    a.  Open Windows Explorer and browse to the C:\Windows\assembly folder

    b.  Locate the KVS.EnterpriseVault.HttpModule

    c.   Right-click KVS.EnterpriseVault.HttpModule and click Properties

    d.  Select the Version tab and verify that the File version number is 9.0.3.1164

 

7.  Restart the Enterprise Vault Admin Service.


 

On the EV server:

 

1. Restart the SharePoint archiving task

 

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)