BUG REPORT: After upgrading to NetBackup 7.5.0.3 virtual machine (VMware) backups run multiple times, eventually failing with status code 196 reported.

  • Article ID:100008676
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Problem

After upgrading to NetBackup 7.5.0.3, virtual machine backups (VMware) run multiple times, eventually failing with a status 196 when the backup window closes.

 

 

Error Message

Status 196.  The activity monitor will show the parent job of individual backups failing in preprocessing:

06/27/2012 10:31:50 - begin Application Snapshot: Policy Execution Manager Preprocessed
Operation Status: 196

The <install_path>/openv/netbackup/db/failure_history/log.mmddyy files will show the VMware client name as the 2nd entity in the file after the date/time stamp.  This entry should be the VMware backup host.

Example:

Policy Name:       ESX_BACKUP
Client/HW/OS/Pri/DMI:  <VM-NAME> vmx-04 rhel5_64Guest 0 0 0 0 ?
VM proxy backup host:  BACKUP_SERVER1

But the failure history only shows entries for <VM-NAME> (it should be BACKUP_SERVER1):

06/27/12 00:06:47 <VM-NAME> ESX_BACKUP Differential-Inc 196 *NULL* 842 1340770007 [VM-NAME]
06/27/12 00:06:47 <VM-NAME> ESX_BACKUP Differential-Inc 196 *NULL* -1 1340770007 [VM-NAME]%5fSnapshot
06/27/12 00:20:46 <VM-NAME> ESX_BACKUP Differential-Inc 196 *NULL* 842 1340770846 [VM-NAME]
06/27/12 00:20:46 <VM-NAME> ESX_BACKUP Differential-Inc 196 *NULL* -1 1340770846 [VM-NAME]%5fSnapshot 

 

Cause

This problem is caused by the use of the incorrect usage of the VMware client name in the failure_history log files versus the VMware backup host name. 

Solution

The formal resolution for this issue (Etrack 2836511) is included in the following release:

  • NetBackup 7.5 Maintenance Release 4 (7.5.0.4)

Information on NetBackup 7.5.0.4 is now available in the Related Article linked below.

An Emergency Engineering Binary (EEB) replacement for nbpem is available for NetBackup 7.5.0.3 which contains a fix for this issue.  To obtain this EEB, please access the Related Article linked below.

Workaround:
1. Stop NetBackup services on master.
2. Remove files from /usr/open/netbackup/db/failure_history (after getting copies of the logs for advancement)
3. Remove file pempersist:
/usr/openv/netbackup/db/jobs/pempersist
\veritas\netbackup\db\jobs\pempersist
4. Restart services.

*** Note this is a temporary work around only.  The problem will resurface as soon as a VMware backup failes for any reason.

 


Related Articles

7.5.0.4 Download Links

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