ODBC error Update to catalog index (Catalog index database) failed after a backup completes on a MMS server in a CASO environment.

Problem

ODBC error Update to catalog index (Catalog index database) failed after a backup completes on a MMS server in a CASO environment.  Restore selection and certain restore jobs many not run properly when run from certain media servers in the CASO/MMS environment after the ODBC errors have occurred.

Error Message

Update to catalog index (Catalog index database) failed.

 

Update to catalog index (Catalog index database) failed. Reason:  [Microsoft][ODBC SQL Server Driver][SQL Server]Violation of PRIMARY
KEY constraint 'PK_CatResourceNameNode'. Cannot insert duplicate key in object 'dbo.CatResourceNameNode'. cat_RecordSet::ExecuteBulkInsert()
e:\nicobar\5204r\becat\segodbc\seg_odbc.cpp(3113) sp_sproc_columns CatResourceNameNodeProc

 

Cause

Catalog indexing corruption occurred on the CASO server.

Manual catalog indexing may have been performed with the Backup Exec service started.

 

Solution

Run Catrebuildindex on the server reporting ODBC errors with the Backup Exec services stopped.

1. Stop the Backup Exec services

2. Open a cmd prompt to folder "X:\Program Files\Symantec\Backup Exec\".

3. Issue the following command:   catrebuildindex -r

    NOTE: Catrebuildindex could take anywhere from several minutes to several hours.

4. Start the Backup Exec services.

 

 


Applies To

Backup Exec 2010 R3

CASO/MMS option.

Backup jobs dispatched from CASO server to MMS servers.

ODBC Events appear on the CASO server after a job is run on a MMS server.

 

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