Upgrade from BE 2010 R3 to BE 2012 fails with the error “Failure -1 running migration library 0” during execution of Pvlupgrade library.

Problem

Upgrade from BE 2010 R3 to BE 2012 fails with the error “Failure -1 running migration library 0”. The failure occurs during execution of Pvlupgrade library.

Error Message

Following error is logged in the BKUPINST2012.log file:

05-15-2012,13:48:58 : In BeMigl MG_Start
05-15-2012,13:48:58 : Running migration library 0
05-15-2012,13:48:58 : library Name m:\Program Files\Symantec\Backup Exec\Migration\pvlupgrade.dll
05-15-2012,13:48:58 : Pvlupgrade: MIG_Start()- start
05-15-2012,13:48:58 : Pvlupgrade: AdammUpgradeView::Upgrade()
05-15-2012,13:48:58 : Pvlupgrade: VersionName = ADAMM 13.5, VersionNumber = 13.5000000000
05-15-2012,13:48:58 : Pvlupgrade: Upgrade to 14.0
05-15-2012,13:49:00 : Pvlupgrade: Start device pool changes
05-15-2012,13:49:00 : Pvlupgrade: DriverConnect:DRIVER=SQL Server;SERVER=ServerName\BkupExec;DATABASE=BEDB;App=BEWS PVLUPGRADE
05-15-2012,13:49:00 : Pvlupgrade: VersionName = ADAMM 13.5, VersionNumber = 13.5000000000
05-15-2012,13:49:00 : Pvlupgrade: AdammUpgradeView::Initialize() = 0
05-15-2012,13:49:00 : Pvlupgrade: ConvertB2DToDiskStorageDevicePerVolume
05-15-2012,13:49:00 : Pvlupgrade: ConvertB2DToDiskStorageDevicePerVolume - End
05-15-2012,13:49:00 : Pvlupgrade: CreateInternalDiskImageMediaSet - failed
05-15-2012,13:49:00 : Pvlupgrade: MoveFixedDiskMediaRecordsToInternalMediaSet - failed
05-15-2012,13:49:00 : Pvlupgrade: Device pool changes - complete
05-15-2012,13:49:00 : Pvlupgrade: Start OST/NDMP system logon account changes
05-15-2012,13:49:00 : Pvlupgrade: ConvertOstNdmpSystemLogonAccountToAdammCredential - failed
05-15-2012,13:49:00 : Pvlupgrade: OST/NDMP system logon account changes - complete
05-15-2012,13:49:00 : Pvlupgrade: Start imported OST device changes
05-15-2012,13:49:00 : Pvlupgrade: ConvertImportedOstDevices - failed
05-15-2012,13:49:00 : Pvlupgrade: Imported OST device changes - complete
05-15-2012,13:49:00 : Pvlupgrade: Upgrade to 14.0 - failed
05-15-2012,13:49:00 : Pvlupgrade: VersionName = ADAMM 14.0, VersionNumber = 14.0000000000
05-15-2012,13:49:00 : Pvlupgrade: MIG_Start() - end
+ 05-15-2012,13:49:00 : Failure -1 running migration library 0
05-15-2012,13:49:00 : Destructor BEMigrate Freeing library: m:\Program Files\Symantec\Backup Exec\Migration\pvlupgrade.dll
05-15-2012,13:49:00 : Destructor BEMigrate Freeing library: m:\Program Files\Symantec\Backup Exec\Migration\jobmigration.dll
05-15-2012,13:49:00 : Destructor BEMigrate Freeing library: m:\Program Files\Symantec\Backup Exec\Migration\catupgrade.dll
05-15-2012,13:49:00 : Destructor BEMigrate Freeing library: m:\Program Files\Symantec\Backup Exec\Migration\postmigrationprocessing.dll
+ 05-15-2012,13:49:00 : BE Migration Tool execution failed
05-15-2012,13:49:00 : Migration returned value: 4294967295
05-15-2012,13:49:00 : Bemig returned
05-15-2012,13:49:00 : Migration failed returning error: 4294967295
 

Solution

A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

Backup Exec 2012 Rev 1798 Service Pack 2 (TECH203155)
 

Please select the option to Roll back the Installation to previous version, and then retry the upgrade using the Backup Exec 2012 SP2 or later embedded installation media to resolve the issue.  The latest media can be downloaded via MyVeritas portal (See http://www.veritas.com/docs/000100418)

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)