Items recently deleted prior to closing an Archive will not be removed from the Vault Store JournalDelete table.

Article: 100027182
Last Published: 2021-09-01
Ratings: 2 0
Product(s): Enterprise Vault

Problem

If there are recently deleted archived items pending, the items in question will not be moved and will not be cleaned up as they belong to an archive which is closed.

Error Message

During the Move Archive, it is possible to receive the following error during the Shortcut update phase when it encounters shortcuts which relate to recently deleted archived items:

"The shortcut was not updated because the item was not moved or because the item does not exist in the source archive"

Note: Moves which encounter this issue will finish with a status of 'Completed with Errors'.

Cause

When items are deleted from an archive, the items in question are added to the Vault Store Database's JournalDelete table to be processed. After performing a Move Archive, the Source Archive will be changed to a Closed state. When the Archive is closed, the associated items in the JournalDelete table will not be processed.  

Notes:
    a. The option 'Enable recovery of user deleted items' under Site Properties - Archive Settings will extend the time which items will be held in the JournalDelete table.
    b. During a move operation, Move Archive does not copy deleted items from the source archive to the destination archive.

 

Workaround:

Temporarily change the Archive State from Closed to Active to allow the items to be processed from the JournalDelete table.

1.    Within SQL Enterprise Manager run the following SQL Query:USE EnterpriseVaultDirectory 

SELECT *
FROM Archive
WHERE ArchiveStatus = 3

2.    Review the results and identify the Archive in question under the ArchiveName column. Record the RootIdentity value for this entry

3.    Run the following SQL query to change the State from "Closed" (Value 3) to "Active" (Value 1)

USE EnterpriseVaultDirectory 
UPDATE Archive 
SET ArchiveStatus = 1 
WHERE ArchiveStatus = 3 AND RootIdentity = <RootIdentity taken from step2>

Confirmation that items for archive have been removed:

1. Identify the ArchiveId for the Archive in question.

    a. Within the Vault Administration Console (VAC), expand Archives > Exchange Mailbox.

    b. Locate the archive in question.

    c. Right-click on the Archive and select Properties.

    d. Select the Advanced tab and record the Archive ID value. 

2. Run the following SQL query to perform a count of items within the JournalDelete table which are associated with the Archive.

USE <VaultStoreDatabaseName>
SELECT count(*)
FROM JournalDelete
WHERE ArchiveId = '<ArchiveId>'

Once the count from Step 2 returns 0 items, the archive in question may be closed and/or deleted if required. 

Solution

Veritas has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article.

There are currently no plans to address this issue by way of a cumulative hotfix or service pack in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time, but is not scheduled for any release. If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns. For information on how to contact Veritas Sales, please see https://www.Veritas.com.

 

 

References

Etrack : 2756213

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