ODBC error "Access to catalog index (Catalog index database) failed" appears every four hours on Backup Exec 2012 server.

Problem

Every four hours, Backup Exec 2012 will generate ODBC events in the Alerts as well as the Application Event Log on the Backup Exec Media Server.

Error Message

 

ODBC access error. Possible lost connection to database or unsuccessful access to catalog index in the database.

 

Cause

Application Log Errors:

 

Event ID:      34326
Description:
Access to catalog index (Catalog index database) failed.
Reason:  [Microsoft][ODBC Driver Manager] Fehler in der Funktionsreihenfolge cat_RecordSet::GetRecordCount()
r:\honshu\1798r.amd64\becat\segodbc\seg_odbc.cpp(4063)
SELECT [ImageGuid], [MediaGuid], [ImageName], [CartridgeLabel], [DeviceGuid],
[ImageLocation], [ImageStorageUsageByte], [ImageExpirationTimeUTC],
[JobHistoryGuid], [ContainerGuid] FROM [dbo].[CATDLM_GetExpirableImage_BE]
(?, ?, ?, ?, ?, ?)   

  

Event ID: 34338
Description:
Backup Exec message: Catalog Error
(Server: "ServerName") ODBC access error. Possible Cause: Closed Connection to database or unsuccessful access to catalog index in the database.

 

Solution

 

This issue is resolved by applying Backup Exec 2012 Service Pack 1a (TECH186717).
 

 

After applying Backup Exec 2012 Service Pack 1a, it may be necessary to run a Backup Exec SQL script against the Backup Exec database (TECH190352).

 


Applies To

Backup Exec 2012

 

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