Event 41293, 41301 Indexing Service start up error: (503) Server Unavailable

Problem

Enterprise Vault (EV) Indexing Service fails to start. The server reports "is too busy"  and returns a (503)  Server unavailable error.  This shuts down the EVIndexingPool and the EVAdminIndexingService.

Error Message

System Event log:

Source: Microsoft-Windows-WAS
Event ID: 5021
Task Category: None
Level: Warning
Description: The identity of application pool DefaultAppPool is invalid.
The user name or password that is specified for the identity may be incorrect, or the user may not have batch logon rights. If the identity is not corrected, the application pool will be disabled when the application pool receives its first request.  If batch logon rights are causing the problem, the identity in the IIS configuration store must be changed after rights have been granted before Windows Process Activation Service (WAS) can retry the logon. If the identity remains invalid after the first request for the application pool is processed, the application pool will be disabled. The data field contains the error number.
V-437-5021

Source: Microsoft-Windows-WAS
Event ID: 5057
Task Category: None
Level: Warning
Description: Application pool DefaultAppPool has been disabled.
Windows Process Activation Service (WAS) did not create a worker process to serve the application pool because the application pool identity is invalid.
V-437-5057

Source: Microsoft-Windows-WAS
Event ID: 5059
Task Category: None
Level: Error
Description: Application pool DefaultAppPool has been disabled.
Windows Process Activation Service (WAS) encountered a failure when it started a worker process to serve the application pool.
V-437-5059

Enterprise Vault Event Log:

Event ID: 41293
Task Category: Index Admin Service
Level: Error
Description: An unexpected error has occurred.
Error Summary: Indexing Service start up error
Error Details: The HTTP service located at http://localhost/evindexing/Index Engine.aspx?v.app=api-soap& is too busy.
The remote server returned an error: (503) Server Unavailable.
V-437-41293

Event ID: 41301
Task Category: Index Admin Service
Level: Error
Description: The Indexing Service could not complete all the required shutdown routines in the allocated time. Service will be stopped anyway. 
V-437-41301

Cause

Appears that AppPoolIdentity was being used as the Identity in the Application pools In IIS 7.5.  Enterprise Vault is supposed to work with either.  However, sometimes this issue may occur, regardless.

Solution

This issue can be resolved by changing the Application Pool identity from AppPoolIdentity to Network Service identity.

1. Login to affected EV Server using Vault Service Account (VSA) username and password.
2. Go to IIS Management Console and change the identity in the Application Pools for the EVIndexingPool from the AppPoolIdentity to the Network Service.
3. Run iisreset and start the EV Indexing Service.


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)