Unable to manually archive and view archived messages in Exchange 2007 Outlook Web Access

Problem

When users connect to OWA and attempt to manually archive messages they are presented with an "Enterprise Vault - Store in Vault - Webpage Dialog" that does not include any available archives into which mail could be stored.

When users attempt to view archived messages the item is not returned and a banner is shown advising "The archived item is currently unavailable" when clicking on the banner and further message of

"You are being redirected to http://evservername/EnterpriseVault/viewmessage.asp? vaultid=?????????????... This web site may not be trusted and may be used to collect personal information, such as your user name and password.  Are you sure you want to continue to this web site? Yes or No.

If selecting yes, a new web page is opened and a message advising that your are now leaving Online Web Access is returned and the archived message is displayed.

Error Message

OWA logging will show the following error:

12/12/2011 13:27:28 [4760,45] [EVServerRequest::CreateRequest] Making request for user: DOMAIN\user
12/12/2011 13:27:28 [4760,45] [EVServerRequest::AddHeader] Set header: X-EVOWA-User-Encoded=46004D005C0070006F006C006C00610073006100
12/12/2011 13:27:28 [4760,45] [RestoreRequest::Send] Exception sending request to restore item: System.Net.WebException: The remote server returned an error: (401) Unauthorized.
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.EnterpriseVault.Owa.EVServerRequests.RestoreRequest.Send()
12/12/2011 13:27:28 [4760,45] [RequestProcessor::RestoreAndActOnItem] Item not restored
 

Cause

A request is issued on behalf of the user who is connecting to OWA by the EVAnon account (X-EVOWA-USER) and in this instance a (401) Unauthorized error is returned suggesting there is a problem with the EVAnon account.

Solution

To investigate further apply the following steps:

1.  Enable OWA logging by adding the following line to the web.config file,

<add key="EnterpriseVault_LogEnabled" value="true""/>

2.  Log into OWA and attempt to manually archive and view and archived message and then log out of OWA.

3.  Browse to c:\Program Files\Enterprise Vault\OWA 2007\logs and review the log file created for the session established in step 2, does the log contain the following:

12/12/2011 13:27:28 [4760,45] [EVServerRequest::CreateRequest] Making request for user: DOMAIN\user
12/12/2011 13:27:28 [4760,45] [EVServerRequest::AddHeader] Set header: X-EVOWA-User-Encoded=46004D005C0070006F006C006C00610073006100
12/12/2011 13:27:28 [4760,45] [RestoreRequest::Send] Exception sending request to restore item: System.Net.WebException: The remote server returned an error: (401) Unauthorized.
   at System.Net.HttpWebRequest.GetResponse()
   at Symantec.EnterpriseVault.Owa.EVServerRequests.RestoreRequest.Send()
12/12/2011 13:27:28 [4760,45] [RequestProcessor::RestoreAndActOnItem] Item not restored

Once the above error is confirmed, follow steps below to verify and/or recreate the EVAnon account:

1. Ensure that the EVAnon account is not disabled or locked out, if the account is not locked out or disabled then proceed to step 2.

2.  Delete and recreate the EVAnon account in Active Directory and verify that the account can log into the domain

3.  Run the OWAUser.wsf script again as per the install and configure guide and then attempt to connect to OWA and manually archive and view archived messages


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)