A 'Data decryption has failed' error is received when a 'Fujitsu Eternus Archive Storage' migrator is used

Problem

The problem have been observed in two different scenarios:
1. The StorageFileWatch process fails to migrate data to the configured Secondary storage when the Collection Task runs

2. Unsuccessful upgrade of Enterprise Vault (EV) as the Storage Service does not start because the upgrade of the Vaultstore database fails.

Error Message

The following error is logged in the EV Event log:

Error 8596

Log Name:      Symantec Enterprise Vault
Source:        Enterprise Vault
Date:          15/11/2011 10:21:47
Event ID:      8596
Task Category: Directory Service
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      EVServer.domain.local
Description:
Data decryption has failed. 

Caller: Domain\vaultadmin

Cipher text: EV//AwAAAAAAAACQAAAAKKnoDHDglTWtIlLpJurz/E8mg+JrT7C1L9wMB5LzR0WhMnWEm0/vyJ5cseJJhRKpm1
LLXW5QSNk1cvae4MNtfMdH4vpKR5EBN7BVpPHOS/7mtlfw/VRU9+VkwlDeXp6ozHVJUDckAWc9iPrs0MAAc2tjJ6TPNFd/Lvlra
KgQj/GDaOvuQzmrFeoSOiEjkig/0H31xaUEo9ycBcJ3QlFzg/qjX7CSlRuEd3ntZ4jbZmWMiyrkVl0fc4eE+NAt1JWLdvDew1noPYF
VLC/BNYeg5AjUP8oErxmBCQaqrSMkOVIK0gNVrmYIXiauOu22ncyF

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Enterprise Vault " />
    <EventID Qualifiers="49156">8596</EventID>
    <Level>2</Level>
    <Task>21</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-11-15T10:21:47.000Z" />
    <EventRecordID>482152</EventRecordID>
    <Channel>Symantec Enterprise Vault</Channel>
    <Computer>EVServer.domain.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Domain\vaultadmin</Data>
    <Data>EV//AwAAAAAAAACQAAAAKKnoDHDglTWtIlLpJurz/E8mg+JrT7C1L9wMB5LzR0WhMnWEm0/vyJ5cseJJhRKpm1
LLXW5QSNk1cvae4MNtfMdH4vpKR5EBN7BVpPHOS/7mtlfw/VRU9+VkwlDeXp6ozHVJUDckAWc9iPrs0MAAc2tjJ6TPNFd/Lvlra
KgQj/GDaOvuQzmrFeoSOiEjkig/0H31xaUEo9ycBcJ3QlFzg/qjX7CSlRuEd3ntZ4jbZmWMiyrkVl0fc4eE+NAt1JWLdvDew1noPYF
VLC/BNYeg5AjUP8oErxmBCQaqrSMkOVIK0gNVrmYIXiauOu22ncyF</Data>
  </EventData>
</Event>

Cause

When configuring the Migration option and selecting the  'Fujitsu Eternus Archive Storage', a list of settings for configuring the new Migrator will be available under the 'Advanced' tab as shown below:

 

The list contains a 'Password' setting with a default password. When the EnterpriseVaultDirectory database is being updated accordingly with the 'Fujitsu Eternus Archive Storage' information, a hashed version of the password will be stored in the SQL Database. However, in this case, the hash version of the default password is corrupted.


When Enterprise Vault attempt to validate the password before a Collection/Migration run or during an Upgrade,  it fails when verifying if the hash is valid. At this stage no actual decryption of the password has occurred.

Solution

This issue has been addressed as part of the following releases:

Enterprise Vault 9.0.3
http://www.symantec.com/docs/TECH147782

Enterprise Vault 10.0
http://www.symantec.com/docs/TECH141422 


Applies To

The problem has been reported under the following conditions:
-  Enterprise Vault 8.0.x
-  Enterprise Vault 9.0.1
-  Enterprise Vault 9.0.2 

-  A 'Fujitsu Eternus Archive Storage' is configured to be used as the Migrator
   This option can be find under the 'Migrator' tab of the Partition Settings as shown below:

Terms of use for this information are found in Legal Notices.

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