Special characters such as { used in mailbox names causing inconsistent archiving results

Problem

Mailboxes with {} in the name are failing during scheduled archiving runs & manual archiving as the {} characters are not being interpreted correctly and are being passed to Enterprise Vault as something else. This in turn causes the ArchiveTask.Exe to crash with an application error and provisioning to report a 3361 Event ID.

Error Message

Event Type: Warning
Event Source: Enterprise Vault
Event Category: Archive Task
Event ID: 3361
Date: 12/08/2011
Time: 17:21:34
User: N/A
Computer: SERVER

Description:
Failed to determine the provisioning group for the mailbox /o=OUP/ou=Exchange Administrative Group (TEST)/cn=Recipients/cn=GBLOGGS. This mailbox cannot be processed until the Exchange provisioning task has processed the corresponding user's details. Ensure that a provisioning group includes this user and then run the provisioning task. Error: The mailbox does not have an entry in the Enterprise Vault database. (0xc0040d1e)
V-437-3661

Cause

{} characters are being interpreted incorrectly during the archiving run or manual archives and therefore Enterprise Vault is looking for a mailbox that doesn't exist as it replaces {} with other characters. This has been determined to be caused by the PR_EMAIL_ADDRESS_W attribute, which is a Microsoft MAPI attribute. When this value appears to be corrupt then the issue occurs. 

Solution

This issue has been addressed in the following releases:


Enterprise Vault 9.0.4 - Release Details
http://www.symantec.com/docs/TECH147785

Enterprise Vault 10.0.1 - Release Details
http://www.symantec.com/docs/TECH147787


Applies To

Server OS: Windows 2003 R2 SP 2 
 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)