Complete VM restores from differential and incremental backupsets via the SAN transport mode fail with Final Error : " 0xe000958d Failed to get the virtual machine snapshot details. "

Problem

Complete VM restores from differential and incremental backupsets via the SAN transport mode fails with Final Error : " 0xe000958d Failed to get the virtual machine snapshot details. "

Beremote.exe(Backup Exec Remote Agent) crashes simultaneously:
 

 Event ID:      1000
 Description:
 Faulting application name: beremote.exe, version: 13.0.5204.109, time stamp: 0x4e18e5d6
 Faulting module name: vddkWrapper.dll, version: 13.0.5204.113, time stamp: 0x4e56202c
 Exception code: 0xc0000005

The Remote Agent Debug log with AVVI debugging prior to the beremote.exe crash shows:
[fsys\vmvcb]         - SymVmTools: PopulateVmEntryWithSnapshotInfo: SYM_VMC_ERROR:  FAILED_TO_GET_SNAPSHOT_MOR
[fsys\vmvcb]         - SymVmTools: GetAllSnapshotDiskDetails: SYM_VMC_ERROR:  RETRIEVE_SNAPSHOT_MOR_FAILED
[fsys\vmvcb]         - VM_VCBPROXY_FS::GetAllSnapshotDiskDetails: failed, result = 0X35
[fsys\vmvcb]         - VM_VCBPROXY_FS::createSnapshotForRestore() Could not get the disk details from the snapshot Symantec Backup Exec for the the newly
created VM 'VM-Name'

[fsys\vmvcb]         - VM_VCBPROXY_FS::DisconnectFromVCServer: vmcDisconnect session = 0000000008564B80
[fsys\vmvcb]         - VM_VCBPROXY_FS::DisconnectFromVCServer: status = 0X0
[fsys\vmvcb]         - VM_VCBPROXY_FS::handleNonStagedRestoreMetaData() Could not create the VM New Virtual Machine.
[ndmp\loops]         - LP_ENV::MsgError: error 0xe000958d processing object New Virtual Machine

Error Message

0xe000958d - Failed to get the virtual machine snapshot details.
Final error category: Resource Errors(V-79-57344-38285)

Restore- VMVCB::\\ESX/VC\VCGuestVm\ha-datacenter\vm\VM-Name VMVCB::\\ESX/VC\VCGuestVm\ha-datacenter\vm\VM-Name

Error writing file data.

Connection to the restore target has been lost.  Operation canceled.

Solution

A hotfix is now available for this issue in the current version(s) of the product(s) mentioned at the end of this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.
 

 

Applies To

This issue occurs while restoring complete virtual machines using Backup Exec Agent for VMWare Virtual Infrastructure from differential and incremental backupsets on tape or backup-to-disk.

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)