64-bit client cannot publish Enterprise Vault (EV) forms to the Personal Forms Library

Problem

When the advanced Desktop Policy 'Deploy Forms Locally' is set to 'Always' (default) or 'When no Org Forms', the EV Outlook client attempts to copy the EV Exchange forms from the install folder into the user's Personal Forms Library. This fails on a 64-bit client.
 

Error Message

The EV client log shows the following error:

DesktopCommon::GetLanguageFolderPath: 0x0
~DesktopCommon::GetLanguageFolderPath: 0x80070002
Unable to load EV forms into Personal Form Library

Cause

The issue occurs because the client is trying to read the InstallPath registry key under:

HKEY_LOCAL_MACHINE\Software\KVS\Enterprise Vault\Install\

However, as the client is x64 the installer has placed the key under:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\KVS\Enterprise Vault\Install\

This prevents the client from locating and installing the form files.

Solution

Workaround Information

The issue can be worked around by creating a copy of the InstallPath value in the native x64 registry, not the wow6432 node. The administrator could roll this out via Group Policy.

 

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.


HKEY_LOCAL_MACHINE\SOFTWARE\KVS\Enterprise Vault\Install

Type - REG_SZ

Value Name - InstallPath

Value Data - <Path to ev root folder>, typically “C:\Program Files (x86)\Enterprise Vault\EVClient\”


This issue is addressed as part of the following release:

Enterprise Vault 10.0
http://www.symantec.com/docs/DOC4441

Enterprise Vault 9.0.3


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