Enterprise Vault (EV) Reports not working after upgrading

Problem

After upgrading to EV9 or higher, the following EV reports no longer function:

  • Vault Store Usage Summary
  • Mailbox Archiving Status

Error Message

Mailbox Archiving Status displays the error: An error has occurred during report processing. (rsProcessingAborted)


Vault Store Usage Summary displays - "There is no data available to display"



 

Running a DTRACE of the W3WP process on the reporting server will give the following information for each EV Vault Store:

(w3wp)  <5828>  EV-H        {ARCHIVESUMMARYREPORTDATAREGION.EN_US} Failed to get vault store information
(w3wp)  <5828>  EV-H        {ARCHIVESUMMARYREPORTDATAREGION.EN_US} Exception: The SELECT permission was denied on the object 'view_WatchFile2', database 'DBNAME', schema 'dbo'. Info: Diag:Num:229 State:5 Sev:14 Svr:SQLSERVERNAME Proc: Line:1 Type:System.Data.SqlClient.SqlException ST:   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)|   at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)|   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)|   at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)|   at System.Data.SqlClient.SqlDataReader.ConsumeMetaData()|   at System.Data.SqlClient.SqlDataReader.get_MetaData()|   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)|   at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)|   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)|   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method)|   at System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method)|   at System.Data.SqlClient.SqlCommand.ExecuteDbDataReader(CommandBehavior behavior)|   at System.Data.Common.DbCommand.System.Data.IDbCommand.ExecuteReader(CommandBehavior behavior)|   at System.Data.Common.DbDataAdapter.FillInternal(DataSet dataset, DataTable[] datatables, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)|   at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet, Int32 startRecord, Int32 maxRecords, String srcTable, IDbCommand command, CommandBehavior behavior)|   at System.Data.Common.DbDataAdapter.Fill(DataSet dataSet)|   at Symantec.EnterpriseVault.Reports.EVReports.ArchiveSummaryReportDataRegion.GetVaultStoreInfo(String sqlServer, String databaseName)
(w3wp)  <5828>  EV-M        {ARCHIVESUMMARYREPORTDATAREGION.EN_US} Leaving ArchiveSummaryReportDataRegion::GetVaultStoreInfo
(w3wp)  <5828>  EV-H        {ARCHIVESUMMARYREPORTDATAREGION.EN_US} Exception: Cannot find table 0. Info: Diag: Type:System.IndexOutOfRangeException ST:   at System.Data.DataTableCollection.get_Item(Int32 index)|   at Symantec.EnterpriseVault.Reports.EVReports.ArchiveSummaryReportDataRegion.GetDataSet(String connectionString, ArrayList parameterCollection)
(w3wp)  <5828>  EV-H        {ARCHIVESUMMARYREPORTDATAREGION.EN_US} vaultStoreDS does not contain any row. Continue with next VaultStores entry

Cause

The EV Reporting user does not have permission to read the requisite view.

Solution

Workaround:

Run the following SQL query against each Vault Store database:

GRANT SELECT ON [dbo].[view_WatchFile2] TO [EVReportingRole]


Veritas has acknowledged that the above-mentioned issue is present in the version(s) of the product(s) referenced in this article.
 
This issue is currently under investigation by Veritas. Pending the outcome of the investigation, this issue may be resolved by way of a cumulative hotfix or service pack in the current or future versions of the software. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.  For information on how to contact Veritas Sales, please see http://www.Veritas.com .
 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
 

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