Event ID 3419 - Scheduled archiving does not run

Article: 100025342
Last Published: 2018-10-15
Ratings: 1 0
Product(s): Enterprise Vault

Problem

Event ID 3419 is generated after every minute, scheduled archiving does not run.

Error Message

[Enterprise Vault Event Log]

Event ID:       3419
Task Category:  Archive Task
Level:          Warning
Keywords:       Classic
User:           N/A
Computer:       EVServer.domain.local
Description:
There was a problem accessing an Exchange 2010 or later server.  The dispenser will re-queue the current item and sleep for 1 minute(s).
V-437-3419

[Dtrace]

Running a Dtrace against the ArchiveTask processes will show the following information:

(ArchiveTask) <5892> EV:L {CExchangeVersion::IsExchange2010orAbove} (Entry)
(ArchiveTask) <5892> EV:M {CExchangeVersion::IsExchange2010orAbove}|Is Exchange 2010 or greater: [True]
(ArchiveTask) <5892> EV:L {CExchangeVersion::IsExchange2010orAbove} (Exit)
(ArchiveTask) <5892> EV:M MAPI error detected for an Exchange 2010 or later target (possible DAG failover) - 0x8004011D

Cause

Enterprise Vault Mailbox Archiving Task for an Exchange Database Availability Group (DAG) member server is created when the Exchange member server does not host an active Exchange database. Thus, the Enterprise Vault Mailbox Archiving Task is not able to communicate with the Exchange 2010 server properly. 

 

Solution

  1. Make sure the Exchange server hosts an active Exchange Database.
     
  2. On the Enterprise Vault server, open Computer Management, expand Services and Applications > Message Queuing then select Private Queues. Verify all Message Queues for the appropriate Exchange Mailbox Task are empty, especially A1 and A6.

    NOTE: Processing for these queues must complete and the queues must be empty before proceeding.  If the queues will not clear, contact Veritas Support Services for further assistance.
     
  3. Open the Enterprise Vault Admin Console, expand Enterprise Vault Servers, expand the Enterprise Vault server and select Tasks.  Right-click the Mailbox Archiving Task for the appropriate Exchange server and select Properties.  Make note of the settings on each tab and of the Exchange server name.
     
  4. Stop the Mailbox Archiving Task.
     
  5. Right-click the Mailbox Archiving Task and select Delete.
     
  6. Return to Private Queues in Message Queuing. Right-click and select Delete for all Enterprise Vault Exchange Mailbox Task message queues for the appropriate Exchange server.  Make sure that the private queue's name contains the Exchange server name from step #3 (i.e. "Enterprise Vault Exchange Mailbox Task for '[ExchangeServerName]' ").

    NOTE: Deleting the incorrect Message Queues will cause issues with other Archiving Tasks on the same Enterprise Vault server.
     
  7. Open the Enterprise Vault Admin Console, expand Enterprise Vault Servers, expand the EV server and select Tasks.  Right-click Tasks and select New > Exchange Mailbox Task.  Work through the wizard using the settings noted in Step #3 above.
     
  8. Start the new Exchange Mailbox Task.
     
  9. Return to Private Queues in Message Queuing and verify the new queues were created.
 

 

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