Why does the Veritas Web Server report it is is not running after upgrade of CommandCentral Storage to version 5.2 RU1?

Problem

The Upgrade process for CommandCentral Storage (CCS) 5.2RU1 does not correctly distribute the updated file "vxccs" on unix platforms. Due to a change in the webserver component in the RU (Release Update) version which can only be applied to the CCS5.2 version the mismatched files will misreport the removed component as not started.

Error Message

After upgrading to CCS5.2RU1, the command /etc/init.d/vxccs reports the incorrect status :-

!!!Veritas CommandCentral Storage Web Engine is not RUNNING!!!

Cause

Before the upgrade under version CCS 5.2

# ls -l /etc/init.d/vxccs

-rwxr-xr-x   1 root     root       42964 Jun  6 13:33 /etc/init.d/vxccs

# ls -l /opt/VRTSccs/VRTSccsts/bin/vxccs

-rwxr-xr-x   1 root     bin        42964 Mar  2  2010 /opt/VRTSccs/VRTSccsts/bin/vxccs

 
After the upgrade to  version CCS 5.2RU1

# ls -l /etc/init.d/vxccs

-rwxr-xr-x   1 root     root       42964 Feb  9 14:39 /etc/init.d/vxccs

# ls -l /opt/VRTSccs/VRTSccsts/bin/vxccs

-rwxr-xr-x   1 root     bin        44672 Jan 21 11:36 /opt/VRTSccs/VRTSccsts/bin/vxccs

 

During the upgrade modifications /opt/VRTSccs/VRTSccsts/bin/vxccs was updated but the change was not propagated to /etc/init.d/

Solution

With a user containing the proper permissions, preferably root, copy the updated file to the /etc/init.d location

 # cp /opt/VRTSccs/VRTSccsts/bin/vxccs  /etc/init.d

Verify the permissions and owner / group are as listed above or change them to reflect the original.


Applies To

Unix platforms where CCS5.2 was upgraded to CCS5.2RU1

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)