Exchange 2010 GRT (Granular Recovery Technology) enabled backup to Tape fails with error:"-546 The log file sector size does not match the sector size of the current volume"

Problem

Exchange 2010 GRT enabled backup to Tape fails with an error:"-546 The log file sector size does not match the sector size of the current volume"

Error Message

Backup Exec Job log shows :
Final error: 0xe0000396 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.
V-79-57344-918 - Unable to complete the operation for the selected resource using the specified options. The following error was returned when opening the Exchange Database file:'-546 The log file sector size does not match the sector size of the current volume.'

Beremote Debug log from Exchange server shows:


DbInstance::TempPath()=<Drive Letter>:\TEMP\Backup Exec\IMG
RSTMAP[0] -  >>>> <Drive Letter>:\TEMP\Backup Exec\IMG\vdb_<Year>_<Month>_<Date>_<somenumber>_<somenumber>\<MailStoreName>.edb
Recovery FAILED - ERROR::RC = -546 - -546 The log file sector size does not match the sector size of the current volume.

Where <Drive Letter> is the drive on the Exchange server which has the largest free space available
           <Year>_<Month>_<Date> is the Day when the Backup is run
           <MailStoreName> is the Name of the mailbox database

Example of the beremote log from Exchange server:

DbInstance::TempPath()=Z:\TEMP\Backup Exec\IMG7
RSTMAP[0] -  >>>> Z:\TEMP\Backup Exec\IMG7\vdb_2011_07_01_0748_19\MailStore1.edb
Recovery FAILED - ERROR::RC = -546 - -546 The log file sector size does not match the sector size of the current volume.

Cause

This error will occur if the temporary staging directory used during backup job i.e "<Drive Letter>:\TEMP" as shown in the beremote debug log, is pointing to a Removable USB drive instead of a local NTFS drive of the Exchange server.

Solution

Change the Temporary staging directory on the Exchange server following the steps given below :

  • Warning : Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes.
  1. On the Exchange Server, click Start -> Run and type "regedit".  Click OK.
  2. Within the Registry Editor, navigate to HKLM\SOFTWARE\Symantec\Backup Exec For Windows\Backup Exec\Engine\Exchange
  3. Right click and add a new String Value, "OnHostTemp".
  4. Right click and set the value of OnHostTemp to "C:\Temp"
  5. Restart the Backup Exec Remote Agent for Windows Systems service on the Exchange Servers.
  6. Run tape backup job of Exchange Resources from media server.

NOTE: Verify that the account(s) used by Backup Exec have full control over the C:\TEMP directory

 

 

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