invalid db login (check credentials)

Problem

invalid db login (check credentials) warning shown in GUI

 

Error Message

invalid db login (check credentials)

 

Cause

database password corrupted for dm database

Solution


stop CCS and the CCS database server

cd into tools directory
C:\>cd "C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS"

shutdown ccs and database
C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS>VxCCS.bat stop -force

confirm shutdown
C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS>VxCCS.bat status

===================================

Then edit the data_server.cfg file (after you made a copy)

C:\Program Files (x86)\VERITAS\CommandCentral Storage Data\Conf\Web Engine\DATA_SERVERS.CFG

change

dm_db_pass=87_-104_-102_89_13_32_-91_77_:99_31_-34_-114_104_-65_91_80_
to
dm_db_pass=ccstor

This will be encrypted on startup again.

===================================
Then change databases.comf
C:\Program Files (x86)\VERITAS\VxDBMS3\Server\conf\databases.conf to include 2 lines that point to your databases like for example:
"C:/Program Files (x86)/VERITAS/CommandCentral Storage Data/Database/ccstor.db" -n ccstor -m
"C:/Program Files (x86)/VERITAS/CommandCentral Storage Data/Database/ccstordm.db" -n ccstordm -m

This should be included in the databases1.conf so please confirm location of the databases and then you may just copy over databases1.conf to databases.conf
===================================
After these steps have been completed, please try to start CCS again:
cd into tools directory
C:\>cd "C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS"

start ccs and database
C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS>VxCCS.bat start

confirm startup
C:\Program Files (x86)\VERITAS\CommandCentral Storage\Support\Tools\VxCCS>VxCCS.bat status

Then log into CCS GUI and check if the message has disappeared.

 


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)