Web analytics tracking cookies cause EV OWA 2010 authentication to fail when accessing shared mailboxes externally.

Problem

Event ID 0 Errors in application event log of the Exchange Server 2010 Client Access Server (CAS). "EVOWA - Request not Authenticated (Could not establish the UserContext)"

Error Message

Log Name:      Application
Source:        Enterprise Vault OWA Extensions
Date:          <Date>
Event ID:      0
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      <EXCHANGE-CAS>
Description:
An unhandled exception was caught in PostRequestHandlerExecute:
   Page: /owa/ev.owa?oeh=1&ns=PendingRequest&ev=FinishNotificationRequest&Fn=1&UA=0
   User: DOMAIN\Usermbx
   HTTP Request Timestamp: <Timestamp Value>

System.Exception: EVOWA - Request not Authenticated (Could not establish the UserContext)
   at Symantec.EnterpriseVault.Owa.Core.EVContext.GetOWASessionId(HttpContextoHttpContext)
   at Symantec.EnterpriseVault.Owa.Core.EVContext.GetEVContext(HttpContextoHttpContext, SecurityIdentifier sid)
   at Symantec.EnterpriseVault.Owa.Core.RequestProcessor.Init(HttpContext oContext)
   at Symantec.EnterpriseVault.Owa.EVOwaModule.PostRequestHandlerExecute(Object objSender, EventArgs objEventArgs)

Cause

This is caused by tracking cookies taking precedence in the order of cookies presented to Exchange Server while authenticating to OWA when accesing a shared mailbox which cause Enterprise Vault OWA Extensions to fail to authenticate. This can be validated when reviewing the IIS log for the above time and URL, it is seen that the authentication fails (401 error message), but then is successfully passed via the EV OWA exceptions handler (200 successful message).

  • 401 Error

    2012-03-20 14:11:13 180.205.32.101 GET /owa/ ae=Item&a=Preview&t=IPM.Note&id=RgAAA...... 443 - 180.5.68.133 Mozilla/5.0+(Windows+NT+5.1;+rv:10.0.2)+Gecko/20100101+Firefox/10.0.2 401 2 5 0
     
  • 200 error = (you can see it gets passed through the exceptions handler)

    2012-03-20 14:11:13 180.205.32.101 GET /owa/forms/premium/SubPageEventHandler.aspx ae=Item&a=Preview&t=IPM.Note&id=RgAAAABIFLqF%2fsHZRJ..... 443 DOMAIN\User 180.5.68.133 Mozilla/5.0+(Windows+NT+5.1;+rv:10.0.2)+Gecko/20100101+Firefox/10.0.2 200 0 0 203

Solution

This issue has been addressed in the following release:

Enterprise Vault 9.0.3 - Release Details
http://www.symantec.com/docs/TECH147782

Enterprise Vault 10.0.1 - Release Details
http://www.symantec.com/docs/TECH147787


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)