Vmware backup job fails with error: 0Xe0009574 - Unable to create a snapshot of the virtual machine

  • Article ID:100024528
  • Modified Date:
  • Product(s):

Problem

Vmware backup job fails with error: 0Xe0009574 - Unable to create a snapshot of the virtual machine. The virtual machine may be too busy to quiesce to take the snapshot.

Error Message

VMware Debug Log Errors:


[fsys\shared]     - vddkCreateVMWareSnapshot(): vmcCreateSnapshotreported: Permission to perform this operation was denied., <0X0>
[fsys\shared]     - LP_ENV::createVMWareSnapshot(): failed, result = 0Xe0009574

or

SymVmTools: CreateSnapshotAPI: SYM_VMC_ERROR:  SOAP_ERROR
[5668] 2013-11-12T15:56:58.851 [fsys\shared]        - SymVmTools: SOAP 1.1 fault: "":ServerFaultCode [no subcode]
"Current license or ESXi version prohibits execution of the requested operation."
Detail: <RestrictedVersionFault xmlns="urn:vim25" xsi:type="RestrictedVersion"></RestrictedVersionFault>
[5668] 2013-11-12T15:57:02.853 [fsys\shared]        - vddkCreateVMWareSnapshot(): vmcCreateSnapshot failed, result = 0X6
[5668] 2013-11-12T15:57:02.853 [fsys\shared]        - vddkCreateVMWareSnapshot(): vmcCreateSnapshot reported: Current license or ESXi version prohibits execution of the requested operation., <0X0>
[5668] 2013-11-12T15:57:02.854 [ndmp\loops]         - LP_ENV::createVMWareSnapshot(): failed, result = 0XE0009574

Cause

This error may occur if the account used for the backup does not have enough permission to transport a snapshot.

This error may also occur if the vStorage APIs are not install on the vCenter / ESX server.

 

Solution

1. Verify that the account used for backup has the proper permissions in vCenter / ESX and on the Backup Exec server. 

2. Verify that the vStorage APIs are installed on the vCenter / ESX server. Use the following document to verify if the vStorage APIs are included with the existing ESX(I) / vSphere license:
000083698
If not please contact VMWare to purchase the appropriate license.

Refer to the related documents to set the required permissions.

 

 

 

Related Articles

What permissions are needed to properly use the Agent for VMware Virtual Infrastructure (AVVI) with Backup Exec 2010 and above

Was this content helpful?

Get Support