Microsoft Exchange 2003/2007 GRT backup to tape/disk fails with error - the Backup Exec Agent for Microsoft Exchange Server did not install completely. The file VirtApi.dll is missing.

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  • Article ID:000012770

Problem

Microsoft Exchange 2003/2007 GRT backup to tape/disk fails with error:0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information and VirtApi.DLL is missing.

Error Message

0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.

V-79-57344-759 - Unable to complete the operation for the selected resource using the specified options because the Backup Exec Agent for Microsoft Exchange Server did not install completely. The file VirtApi.dll is missing. Click Tools, click Install Options and License Keys on this Media Server, and then click Next to run the Install Wizard. On the Features list, ensure that the agent is selected for installation. Continue with the installation, and then retry the operation
 

From Beremote debug log shows:

--------------------------------------------------------------------------------------------------------------------------------------------------

[8440] 01/26/11 20:00:24 [fsys\jet]           - VirtApi DLL WAS LOADED FROM VirtApi.dll.
[8440] 01/26/11 20:00:24
OpenThreadToken failed, lastError = ERROR_ACCESS_DENIED, Access is denied.
[8440] 01/26/11 20:00:24
OpenProcessToken failed, lastError = ERROR_ACCESS_DENIED, Access is denied.
[8440] 01/26/11 20:00:24
Unable to load VirtFile

and

Unable to register process.  Driver is probably not installed correclty.
[8440] 01/26/11 20:00:24 [fsys\jet]            - VirtApi DLL load check failed.
[8440] 01/26/11 20:00:24 [fsys\mb2]        - Using EDB Provider for Browse/Backup.
[8440] 01/26/11 20:00:24 [fsys\mb2]        - Logon: m_lpMAPISession->Logon returned 80004005
[8440] 01/26/11 20:00:24 [fsys\mb2]        -  FILTER DRIVER MISSING: VirtApi.dll

Cause

This can happen if any of the below condition is true:

  • If VirtApi.dll is not registered properly. (If backup to Tape, check this in Exchange server, and if disk backup is used, check this in Media server.)

                  To check this open command prompt and type FLTMC and check whether it shows Virtfile. If not, its not properly registered or installed..

  • The Backup account does not have permissions.
  • BE 2010 or later is installed and the Exchange server's operating system is Windows 2003 without SP2

Solution

Solution 1:

If it is backup to Disk, check below steps.

1. Verify if the Exchange license key is installed.

2. If installed remove and reinstall the Exchange license key from Tools -> Install options and license keys on this media server.

To remove and re-install the license on Backup Exec 2012

  • Click on the Menu Icon on the top left hand corner
  • Choose Installation and Licensing
  • Choose Install Options and licenses on this Backup Exec Server
  • Click on Next
  • Uncheck the Agents for Applications and Databases to proceed with the Uninstallation
  • Follow the same instructions to check Agents for Applications and Databases to proceed with the Installation

3. Verify if the VFF (VIRTFILE.dll) is available.
 
 
4. Retry the backup. 

 

If backup is to tape, first confirm Virtfile is there in Exchange server or not. If it is there, check whether its present in Media server. If media server has it, Re-install Remote agent on the Exchange server. If media server also not listing Virtfile, reinstall Licence as given above and once you got Virtfile, then re-install Remote agent on the Exchange server. After re-installation, make sure Virtfile shows. Then run the backup to Tape.

Solution 2:

1. Check the default account of Backup exec from Network > Logon accounts.

2. Check if the following pemissions are met:

  • Backup account should be a member of Local administrator group and Backup Operators group on both media server and exchange server.
  • Account should have Exchange Full Administrator role( Exchange 2003) / Exchange Organization Administrator role (Exchange 2007).
  • Account should be Unique and should have an active mailbox.
  • Mailbox of the account should not be hidden in Exchange address lists.

3. Retry the backup. 

 

Solution 3:

Install Windows 2003 SP2 (or later) for BE 2010 or later versions.

 

 

Applies To

Microsoft Exchange 2003

Microsoft Exchange 2007

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