Exchange 2010 Restore does not mount database even though NetBackup reports status 0

Problem

In the restore of Exchange 2010 Microsoft Information Store from a Standalone Exchange 2010 environment (not  DAG); the restore completes successfully and shows mounted successfully, but the database does not mount in Exchange Server. Errors are also reported in the Application Event Log.

Error Message

Restore Shows:

15:49:03 2/25/2011: Restore Started
 
15:49:58 (364.001) INF - Database Mailbox Database mounted successfully.
15:49:58 (364.001) INF - TAR EXITING WITH STATUS = 0
15:49:58 (364.001) INF - TAR RESTORED 4 OF 5 FILES SUCCESSFULLY
15:49:58 (364.001) INF - TAR KEPT 1 EXISTING FILES
15:49:58 (364.001) INF - TAR PARTIALLY RESTORED 0 FILES
15:49:58 (364.001) INF - Continuing restore from server nbumaster to client exchange2k8
15:50:00 (364.001) Status of restore from copy 1 of image created 2/23/2011 6:08:30 PM = the requested operation was successfully completed

- Application Event Log:

Microsoft.Exchange.Data.Storage.ConnectionFailedTransientException: Cannot open mailbox /o=netbackup/ou=Exchange Administrative Group (#########)/cn=Configuration/cn=Servers/cn=exchange2k8/cn=Microsoft System Attendant. ---> Microsoft.Mapi.MapiExceptionNetworkError: MapiExceptionNetworkError: Unable to make connection to the server. (hr=0x80040115, ec=-2147221227)

Cause

Selecting from the Information Store in the left pane/window will cause the database to not mount and error MapiExceptionNetworkError: Unable to make connection to the server in Application Event Log.

Solution

Run the restore by selecting the Database and the Transaction Logs from the right hand pane and NOT from the left pane.


Applies To

Master Server: nbumaster

Client Exchange 2010 standalone (not dag): exchange2k8

NetBackup 7.0.1

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