NetBackup hot catalog backup exits with status 1

  • Article ID:100004925
  • Modified Date:
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Problem

When performing a hot catalog backup it exits with status 1

Cause

The issue may be caused by corrupt image header files. Checking the bpbkar log on the master server shows the following entries:

2:24:09.365 PM: [2740.4732] <4> V_CatBackupWin::V_NextCatBackupDirective: INF - Catalog backup: C:\Program Files\VERITAS\NetBackup\db\images\<server_name>\ALTPATH
2:24:09.365 PM: [2740.4732] <4> V_CatBackupWin::V_NextCatBackupDirective: INF - Catalog backup: CATALOG_BACKUP <server_name> <policy_name>_1272210233_INCR
2:24:09.381 PM: [2740.4732] <4> V_CatBackupWin::V_NextCatBackupDirective: INF - Catalog backup: CATALOG_BACKUP <server_name> <policy_name>_1272330167_FULL
2:24:09.381 PM: [2740.4732] <16> V_CatBackupWin::V_ExpandCatalogBackupDirective: ERR - db_getImgBackupList failed, err: 12. Client: <server_name>, Image ID: <policy_name>_1272330167_FULL
2:24:09.381 PM: [2740.4732] <16> V_CatBackupWin::V_StartCatBackupDirective: ERR - Unable to expand hot catalog backup directive: CATALOG_BACKUP <server_name> <policy_name>_1272330167_FULL

Solution

2:24:09.381 PM: [2740.4732] <16> V_CatBackupWin::V_ExpandCatalogBackupDirective: ERR - db_getImgBackupList failed, err: 12. Client: <server_name>, Image ID: <policy_name>_1272330167_FULL 
 

The highlighted entry above indicates a corrupt image header that will need to be removed as it cannot be backed up. To do this, navigate to the following directory

<install_path>\NetBackup\db\images\<server_name>\<ctime>\ <policy_name> _1272330167_FULL

From here, delete any files that begin with that name in the same folder. It may also be necessary to delete any related files under the catstore subfolder.

(Note: It may be advisable to move these files to another location, then deleted after the issue is resolved.)


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