Backup of Enterprise Vault data fails with error "0x1 - Incorrect function."

Problem

Agent for Enterprise Vault based backup of Enterprise Vault (EV) data fails with one of the error given below

Error Message

"Final error: 0xe000846b - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent.Make sure that the correct version of the Remote Agent is installed and running on the target computer.  If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource"

Or

"Backup of one or more of the EV databases fail with the error - 0x1 - Incorrect function"

Cause

This issue will come up:

  • if there are orphan entries of previous install of EV on either Backup Server or the SQL server which holds the databases for existing EV install.

OR

  • if EV addins of different version are installed either on Backup Exec server or the SQL server holding databases of existing EV install.

Solution

To confirm if the issue faced is the same, enable debugging as directed in How to enable debugging for the Backup Exec Enterprise Vault (EV) agent while backing up EV 8.0 and above or Backup Exec Archive Option (BEAO)

If the debug log on either server has similar entries like below, then proceed with the steps listed below to resolve the issue:

 

[4472] 01/10/11 15:06:56 [fsys\ev]            - evFileSystem::RefreshTopology()

[4472] 01/10/11 15:06:56 [fsys\ev]            - This EV version is not supported by Backup Exec.

[4472] 01/10/11 15:06:56 [fsys\ev]            - evFileSystem::RefreshTopology: Failed while requesting XML.

 

 

I. If EV addings are not installed on Backup Exec or SQL server then follow the steps listed below:

Warning: Incorrect use of the Windows Registry Editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried- out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes. 

1] Export the following registry on the Backup Exec Server or the SQL Server "HKEY_LOCAL_MACHINE\Software\KVS\Enterprise vault\Install\Version" and delete if no Enterprise Vault addin is installed on these servers.

2] Restart the Backup  Exec services on all the concerned servers and run the backup.

 

II. If EV addins exist on the Backup or Database Server then they should be upgraded to same version as the EV install to resovle the issue.


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)