Unable to add or select a Sharepoint 2010 Foundation Farm for backup in Backup Exec 2010 R2, with error "None of the Web servers for the specified server farm could be accessed".

Problem

When attempting to add or select a Sharepoint 2010 Foundation server farm to the backup selection list in Backup Exec 2010 R2, the error "None of the Web servers for the specified server farm could be accessed" is displayed. No Sharepoint resources are left available to select.

 

Error Message

Debug from SPSWrapper.log

[2118] 09/27/10 10:01:24 This is farm identified as  a Portal
[2118] 09/27/10 10:01:24 Request received.
[2118] 09/27/10 10:01:24   Request to execute a Get Topology(0x00000001) command.
[2118] 09/27/10 10:01:24   Command: 0x00000001
[2118] 09/27/10 10:01:24 ::Build Farm Topology
[2118] 09/27/10 10:01:24   Start
[2118] 09/27/10 10:01:24 Inside SPIsThisServerAWebService()
[2118] 09/27/10 10:01:40 Returning True from SPIsThisServerAWebService()
[2118] 09/27/10 10:01:41 Inside Build Lists
[2118] 09/27/10 10:01:46 Inside GetBackupRestoreObjects()
[2118] 09/27/10 10:01:46 Getting BackupRestoreObject xxxxxx_Config
[2118] 09/27/10 10:01:46   Failed to build the data for topology backup
[2118] 09/27/10 10:01:46    Exception !!
System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Office.InfoPath.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

File name: 'Microsoft.Office.InfoPath.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'

   at SPSManagedWrapperHelper.SpsManagedWrapperV3.b(SPBackupRestoreObject A_0)

   at SPSManagedWrapperHelper.SpsManagedWrapperV3.GetBackupRestoreObjects(SPBackupRestoreObjectCollection list)

   at b6.a()

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

 

Cause

It has been seen that having both Sharepoint 2010 Foundation and Search Server 2010 Express installed on the same server causes Backup Exec to incorrectly detect the installation as a full Sharepoint 2010 Portal. When enumerating for selections, we fail to get the required topology for the Sharepoint environment and cannot show the selections.

 

Solution

This issue has been resolved by Backup Exec 2010 R2 Hotfix 148347
www.symantec.com/docs/TECH148347
 


Applies To

Sharepoint 2010 Foundation installed alongside Sharepoint Search Server 2010 Express

 

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)