AVVI backup completes with exception when password for Backup Exec account or Virtual Machine name or its directory contains a special character

Problem

AVVI backup completes with exception when password for the Backup Exec or Virtual Machine name or its directory contains a special character

Issue was initially reported against the ampersand character '&'. However, it may be seen against any non-alphanumeric character with the exception of a space or hyphen.

This exception only causes Granular Restore Technology (GRT) not to function properly. The virtual machine is still backed up and able to be recovered. 

 

Error Message

Errors seen may be one of the following:

V-79-57344-38726 - Backup Exec was unable to connect to virtual machine '<vmpath and name>' and was unable to collect the necessary metadata to restore individual application items

V-79-57344-38721 - Failed to mount one or more virtual disk images

v-79-57344-38278 Unable to find the metadata for a disk of the virtual machine

 

BEREMOTE DEBUG LOG:
VDDK-Log: TicketResolveHostName: Resolving IP address for hostname vcenter.
VDDK-Log: TicketResolveHostName: Resolved to {IP ADDRESS OF VCENTER}.
VDDK-Log: VixDiskLibVim: TicketLogin
VDDK-Warn: VixDiskLibVim: Login failure - VixError = 0.
VMDKRemoteImage::Open() Could not open the disk '[DATASTORE] DIRECTORY/VIRTUALMACHINE.vmdk' Error Text: 'Cannot connect to host' Error: '18000'
CDiskLayoutImplementation::DisableAutoMount: AUTOMOUNT is already disabled
VMwareVirtualSystem::MountDisksUsingVddk() - Enter
VDDK-Warn: Refusing to set temp directory second time 'C:\Windows\TEMP\vmware-SYSTEM' to 'C:\Windows\TEMP\vmware-SYSTEM'.
VDDK-Log: Mntapi_Init Asked - 1.0 Served - 1.0 was successful,TempDirectory: C:\Windows\TEMP\vmware-SYSTEM.
VDDK-Log: TicketResolveHostName: Resolving IP address for hostname vcenter.
VDDK-Log: TicketResolveHostName: Resolved to {IP ADDRESS OF VCENTER}.
VDDK-Log: VixDiskLibVim: TicketLogin
VDDK-Warn: VixDiskLibVim: Login failure - VixError = 0.
VDDK-Warn: VixDiskLibProvider::NameBasedProvider::Get: Unable to open disk [DATASTORE] DIRECTORY/VIRTUALMACHINE.vmdk, openflags = 4 - VixError 0x4650.
VDDK-Warn: DiskLibProvider_GetDisk: Open failed - index 0.
VDDK-Log: Error 2 opening disk 0.
VDDK-Log: VixMntapi: Operation failed with system error: The system cannot find the file specified.
VMDKRemoteImage::mountDisks() Could not open the diskset. Error Text: 'A file was not found' Error: '4'
CDiskLayoutImplementation::SetAutoMount: Disabling AUTOMOUNT

 

Cause

This issue is caused by having the special characters ^, +, = , #, @, $, %, /, \, (, ), {, ]< [, ], &, *, `, >, <, ;, ', ", ! or |  in the password for the account being used to backup the virtual machines, the name of the virtual machine directory or the virtual machine name itself.

 

Solution

 
Do not use non alpha-numeric characters in the virtual machine names and the folders they reside in. Also carefully test where special characters are used within account passwords used by the backup jobs, choosing different characters if a failure is seen.
 
WORKAROUND:
 
Disable File Level and Application GRT in the backup job.
 

 

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