Backup Exec Remote Agent for Windows installation fails with an unexpected error: Invalid Class

Problem

Backup Exec Remote Agent for Windows installation fails with an unexpected error: Invalid Class

Error Message

Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Description: EventType clr20r3, P1 _setup.exe, P2 13.0.173.0, P3 4b17cf73, P4 s

ERROR: Installation failed with error -532459699. GetLastError = :

 During push installation of Backup Exec Remote Agent for Windows System, following error is observed :
 "WMI is not accessible or disabled or may be blocked by the firewall" or " fails with error 1603"
 

During local installation of Backup Exec Remote Agent for Windows System, the following error is observed :
 
RAWSInst.htm shows:
 
The install failed with an unexpected error:
 
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext() at Symantec.BackupExec.AgentSeqDlgs.AgentInstaller.GetVMwareGuest() at Symantec.BackupExec.AgentSeqDlgs.AgentInstaller.GetMSICommandLine() at Symantec.IFrameSDK.Iframe2.ProductInstaller.StartInstall(BaseDialog dlg) at Symantec.BackupExec.AgentSeqDlgs.AgentInstaller.StartInstall(BaseDialog dlg) at Symantec.IFrameSDK.Iframe2.MultiProductInstaller.Install_Product_Thread() at System.Threading.ThreadHelper.ThreadStart_Context(Object state) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) at System.Threading.ThreadHelper.ThreadStart() 04-13-2010,08:52:04 : If this install is being run from a network share, copying the media locally and retrying the install may resolve this issue. 
 
ERROR: Installation failed with error -532459699. GetLastError = :0
 
Other errors observed:
 
The install failed with an unexpected error: Object reference not set to an instance of an object.
 
ERROR: Installation failed with error -1073741819. GetLastError = :0
 
Figure1
 
  
 

 

Cause

WMI Service is not started and the properties of WMI Control shows Invalid class or Access Denied.
 
 

Solution

Solution 1 :- Start WMI Service
 
Check the Windows services snap-in and verify that the Windows Management Instrumentation service is started and running.
 
Solution 2: Corrupt WMI
 
If there are any issues found with WMI, take corrective action and resolve the issues with WMI.
 
Solution 3: Add the service account into the Local Administrator's Group
 
Verify that the account being used to perform the installations is a part of the local administrator's group.
 
Solution 4: Install Microsoft Dot Net Version 2 Service Pack 2
 
If Microsoft .Net SP2 is not installed, please install it. You can download it from  http://www.microsoft.com/downloads/details.aspx?familyid=5b2c0358-915b-4eb5-9b1d-10e506da9d0f&displaylang=en 
 
Solution 5: Install Service Pack 1 for Backup Exec 2010
 
The fix for the GetVMwareGuest error above has been released in Service Pack 1 for Backup Exec 2010. It can be obtained from http://www.symantec.com/docs/TECH136199

Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)