Event IDs 7046 or 7082 when setting/clearing backup mode: "Unable to set or clear backup mode, Storage Service is not running"

Problem

When attempting to set or clear backup mode, an error occurs and the following Events are generated in the Event Viewer.

Error Message

Event IDs 7046 or 7082 may be generated within the Enterprise Vault event logs with the error, "Unable to set or clear backup mode, Storage Service is not running."

V-437-7046

V-437-7082

Cause

After setting or clearing backup mode in Enterprise Vault 8.0, these processes perform the following actions:

StorageManagement.exe:

 
  • The StorageManagement process first attempts to stop the StorageFileWatch.exe and StorageDelete.exe processes
  • StorageManagement toggles certain variables in memory to set or clear backup mode
  • StorageFileWatch and StorageDelete are restarted

StorageFileWatch.exe:

 
  • The StorageFileWatch process (when entering backup mode) stops all collector threads but remains running in memory to perform necessary read-only operations
  • When exiting backup mode, collector threads are restarted in normal mode to begin data collection

StorageDelete.exe:

 
  • The StorageDelete process (when entering backup mode) stops all deletion threads but remains running in memory
  • When exiting backup mode, all deletion threads are restarted, SQL 'cleanup' threads are executed, and the process resumes normal operation


Part of the responsibility of StorageDelete is to maintain several Vault Store database tables by removing any 'stale' records and/or records older than the archive transaction history specified within the Enterprise Vault site properties (by default, this is 32 days). The 'cleanup' threads execute several SQL queries and stored procedures, and these queries may take time to execute. If multiple Vault Stores that are maintained by the same Enterprise Vault Storage Service are placed into backup mode at the same time, the StorageManagement process will have difficulty shutting down StorageDelete threads that are still attempting to execute these queries within SQL, which will cause the "Storage Service is not running" error to be reported.

Solution

Workaround:

If sharing has not been enabled between multiple Vault Stores within a Vault Store Group (such as the Default Upgrade Group):

1. Create a new Vault Store Group for each Enterprise Vault server
2. Move the Vault Stores maintained from each Enterprise Vault server into the appropriate Vault Store Group
3. Change backup mode procedures within your environment to set and clear backup mode for each Vault Store Group on a per-server basis

If sharing has been enabled, Vault Stores may not be moved to new Vault Store Group:

1. Change backup mode procedures within your environment to set and clear backup mode for the entire Vault Store Group


Once these changes have been completed, by placing the entire Vault Store Group into backup mode, this issue will be alleviated as the processes will only restart once.


Solution:
This issue has been addressed in the following release:

 


Terms of use for this information are found in Legal Notices.

Search

Survey

Did this article answer your question or resolve your issue?

No
Yes

Did this article save you the trouble of contacting technical support?

No
Yes

How can we make this article more helpful?

Email Address (Optional)