Restore of an Exchange 2010 database to the Recovery Database fails with the error "The Exchange server was not found"

Problem

Restore of an Exchange 2010 database to the Recovery Database fails with the error "The Exchange server was not found".

Error Message

Backup Exec attempted to restore an Exchange database according to the job settings. The Exchange server was not found.

Cause

Restore of an Exchange 2010 database to the Microsoft Exchange 2010 Recovery Database fails with the above mentioned error message if correct options were not selected in the restore job. For example; this error is observed if the option "Redirect to Recovery Storage Group (RSG)" instead of "Restore to Database or Recovery Database" is selected under Microsoft Exchange Redirection.

Solution

To restore an Exchange database to the recovery database the following options should be configured in the restore job:

1. Under "Microsoft Exchange Redirection" select the option "Redirect Exchange Sets" and specify the Exchange server name under "Restore to server".

2. Select the option "Redirect using Volume Shadow Copy Service (VSS) snapshot provider."
 
3. Ensure that the Backup Exec Remote Agent Service on the Exchange Server is running on Local System Account.

4. Select the option "Redirect to storage group and/or Database (Exchange 2007 or later only)" and specify the name of the Recovery Database under "Restore to Database or Recovery Database" as shown in the Figure 1 below:

Figure 1:

  
 
 

 

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