Perl dependency errors installing Veritas File System (VxFS) 5.1 for Linux on RHEL5

  • Article ID:100001053
  • Modified Date:
  • Product(s):

Problem

Perl dependency errors installing Veritas File System (VxFS) 5.1 for Linux on RHEL5

Solution


Introduction:

You may see perl dependency errors installing VxFS 5.1. VxFS provides a simple data placement tool, mkdstfs and this tool uses /usr/bin/perl.


How to Determine if Affected:

If you try to install 5.1, you may see the following:

# rpm -i VRTSvxfs-5.1.00.00-A39_RHEL5.x86_64.rpm
error: Failed dependencies:
       /usr/bin/perl is needed by VRTSvxfs-5.1.00.00-A39_RHEL5.x86_64
       perl(Getopt::Std) is needed by VRTSvxfs-5.1.00.00-A39_RHEL5.x86_64
       perl(constant) is needed by VRTSvxfs-5.1.00.00-A39_RHEL5.x86_64
       perl(strict) is needed by VRTSvxfs-5.1.00.00-A39_RHEL5.x86_64


Workaround:

Install a RHEL5 package on the system containing /usr/bin/perl.


Formal Resolution:

Veritas will change the mkdstfs perl script to point to the perl utility from the VRTSperl package. This will be fixed in 5.1 Rolling Patch (RP) 1.


Best Practices:

Veritas strongly recommends the following best practices:
1. Always perform a full backup prior to and after any changes to your environment.
2. Always make sure that your environment is running the latest version and patch level.
3. Perform periodic "test" restores.
4. Subscribe to technical articles.



Related Articles

Updates, Patches and Late Breaking News for Release Notes for Storage Foundation and High Availability Solutions 5.1, 5.1 PR1 and 5.1 SP1 on Linux

Was this content helpful?

Get Support