Problem
Lifecycle Management policies should not be applied on Cloud Storage supported by Backup Exec
Error Message
Error in Adamm Log -
DeviceIo: ostutil: Azure:azure:azure.com FindOstInfo missing BEOST_SInf AND LSU is not empty 'BEOST_00000001'
DeviceIo: Azure:azure:azure.com:archive0920: 490CFBDD498791AD creating BEOST_SInf
[07752] 09/09/20 14:35:19.835 DeviceIo: sts_create_image BEOST_SInf BEOST_SInf 2060001
Cloud Storage goes offline.
Cause
Backups are written in chunks and stored on the cloud storage. The backup set is stored on media which show up as BEOST_00000001 etc. folders in the cloud container/bucket. Along with that, to give that container/cloud storage its identity, a unique serial number is stored in folder called BEOST_SInf ( backup -> BEOST_SInf-Bak). There is also another folder called the BEOST_Smap and this contains the slot map of the media present in the Cloud storage.
In order for the storage to remain online, the content of the BEOST_SInf should remain available all the time in the Hot or Cool tier ( and not in archive ). This is true for other cloud vendor storages as well. If Backup Exec wrote to standard tier (eg: AWS etc.) storage and without knowledge of Backup Exec using some scripts or policies if some files from storage are moved to a less costly tier storage then the storage may go offline within Backup Exec if the file moved was BEOST_SInf. As for rest of the files, restores would only work if the content of BEOST_0000* files are brought back to the same tier on which the backup was done.
Solution
Archiving the content of Azure storage via Lifecycle Management policy is not supported by Backup Exec. The Lifecycle Management policy if applied on storage cause the files in the container to be archived and moved out which in turn renders the storage offline in Backup Exec. Inventory of the Media blocks which are archived would also fail.
If content of Azure ( hot or cool tier storage) is already archived ( which is strictly not supported ) and this situation is found out then all the chunks from inside the BEOST_Sinf, BEOST_SMap and other BEOST_0* need to be moved back to the Hot or Cool tier and Lifecycle Management Policy should be removed from that container.
Note: Movement of the blocks from archive to hot or cool tier takes time and would draw charges. This affects recovery time objective when a need to restore arises. For Inventory and Catalog to work, all data should be first made available in Hot or Cool tier of Azure storage.
Backup Exec Technical support can be contacted if the BEOST_Sinf or BEOST_Sinf-Bak is not found in the cloud storage as without these folder, the cloud storage will not come online in Backup Exec.