Getting 'The hostnames defined in the license do not match those configured in the system' error when upgrading

Article: 100045261
Last Published: 2019-03-11
Ratings: 1 0
Product(s): APTARE IT Analytics

Problem

Getting 'The hostnames defined in the license do not match those configured in the system' error when upgrading

Error in the upgrade.log:

Upgrader is unable to proceed: The current system configuration exceeds the license parameters.
Please run c:\opt\aptare\utils\verifyLicense.bat for details of the license overage and contact your support or sales organization for further assistance.

Following customers will run into this issue:

Customer has DPD license

OR

1) Customer is not licensed for BM
2) Customer is collecting from CM
3) Customer is collecting DDM Capacity Manager


This issue was introduced when we split Data Domain collection into Capacity Manager and Backup Manager in SC 10.2.00

Cause

Getting-The-hostnames-defined-in-the-license-do-not-match-those-configured-in-the-system-error-when-upgrading. This error happens when upgrading from any version between SC 10.2.00 and SC 10.2.01 P2 to SC 10.2.01 P3 or higher.

Solution

Workaround:

1) select host_id from apt_host_detail where backup_server_type=92;
--Save these host_ids for later use.
2) Update all the DDM master servers to make them client as follows:
UPDATE apt_host_detail set backup_server_type=1 where backup_server_type=92;
commit;
3) Run the upgrade.sh(bat)
4) After the upgrade, set the backup_server_type to original value using the host_ids from step # 1 above
UPDATE apt_host_detail set backup_server_type=92 where host_id IN (<<HOST IDS FROM STEP # 1>>);
commit;

Applies To

10.2.00, 10.2.01, and above

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