Enterprise Vault installation wizard crashes while upgrading to EV 12.3

Article: 100044399
Last Published: 2018-11-13
Ratings: 1 0
Product(s): Enterprise Vault

Problem

While running the Enterprise Vault installation wizard to upgrade to EV 12.3, the wizard crashes.

Error Message

No error is logged in the Application, System, or Veritas Enterprise Vault event logs.

However, the EVInstall log shows an error. This log can be found under [EV installation folder]\Installation Logs.

11-13-2018: 11:11:32: DllRegistrationHandler Begin: PreReqScan.dll
11-13-2018: 11:11:32: Change Dir: H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\
11-13-2018: 11:11:32: H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\PreReqScan.dll
11-13-2018: 11:11:32: WriteFileRegisterFile Begin: "C:\Windows\system32\regsvr32.exe" "H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\PreReqScan.dll" /s
11-13-2018: 11:11:32: WriteFileRegisterFile Ended: "C:\Windows\system32\regsvr32.exe" "H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\PreReqScan.dll" /s
11-13-2018: 11:11:32: LaunchReturnErrorLevel Begin "C:\Windows\system32\regsvr32.exe" "H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\PreReqScan.dll" /s
11-13-2018: 11:11:32: EVRegFile.log missing. No return code.
11-13-2018: 11:11:32: DeleteFile: H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\EVRegFile.Bat
11-13-2018: 11:11:32: LaunchReturnErrorLevel Ended "C:\Windows\system32\regsvr32.exe" "H:\Temp Folder\2\{F5E79328-3509-4CBE-A945-596F815762B8}\PreReqScan.dll" /s
11-13-2018: 11:11:32: DllRegistrationHandler Ended: PreReqScan.dll

 

Contrast this with the expected result in a working EVInstall log:

10-28-2018: 10:47:12: DllRegistrationHandler Begin: PreReqScan.dll
10-28-2018: 10:47:12: Change Dir: C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\
10-28-2018: 10:47:12: C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\PreReqScan.dll
10-28-2018: 10:47:12: WriteFileRegisterFile Begin: "C:\Windows\system32\regsvr32.exe" "C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\PreReqScan.dll" /s
10-28-2018: 10:47:12: WriteFileRegisterFile Ended: "C:\Windows\system32\regsvr32.exe" "C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\PreReqScan.dll" /s
10-28-2018: 10:47:12: LaunchReturnErrorLevel Begin "C:\Windows\system32\regsvr32.exe" "C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\PreReqScan.dll" /s
10-28-2018: 10:47:12: File Reg Return Code: 0
10-28-2018: 10:47:12: File successful.
10-28-2018: 10:47:12: DeleteFile: C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\EVRegFile.Bat
10-28-2018: 10:47:12: DeleteFile: C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\EVRegFile.log
10-28-2018: 10:47:12: LaunchReturnErrorLevel Ended "C:\Windows\system32\regsvr32.exe" "C:\Users\VERITA~1\AppData\Local\Temp\{43709D99-47D7-44B4-ADBA-E5C91D9EEA13}\PreReqScan.dll" /s
10-28-2018: 10:47:12: DllRegistrationHandler Ended: PreReqScan.dll

Cause

An issue with the temp folder is preventing the creation of the EVRegFile.log file.

Solution

Solution 1: Modify the permissions of the temporary folder(s) on the machine such that the Vault Service Account has full control.

Solution 2: Change the location of the temporary folder(s) to one over which the Vault Service Account has full control. This article includes step-by-step instructions on how to change this.

 

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