Data backed up from a FIFO file using NetBackup with Client Encryption enabled may not be encrypted and may be scrambled during restore

Article: 100042440
Last Published: 2018-03-16
Ratings: 0 0
Product(s): NetBackup

Problem

Data backed up from a FIFO file with Client Encryption enabled may not be encrypted and may be scrambled during restore.

Error Message

No error message is displayed during backup or restore. The restore job may be shown as successful but restored data may be scrambled.

Cause

NetBackup does not encrypt the data from a FIFO file during backup, but applies the encryption key to restored data, causing them to be scrambled.

Solution

Veritas Technologies LLC has acknowledged that the above-mentioned issue (Etrack 3940933) is present in the current version(s) listed under the Product(s) Section of this article. Veritas Technologies LLC is committed to product quality and satisfied customers.

Veritas Technologies LLC currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here. A link to the patch or hotfix download will be added to this document when it becomes available. Please note that Veritas Technologies LLC reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Veritas’ plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Veritas Sales, please see   https://www.veritas.com

Workaround:

An Emergency Engineering Binary (EEB) containing a fix for this issue for NetBackup 7.7.3 is available by contacting Veritas technical support, referencing this article id and Etrack 3940932.

This EEB has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of a hotfix.

References

Etrack : 3940933

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