Problem
Following the upgrade of Folder Sync, an issue may be encountered with all mailboxes where Mailbox has no endpoint associated with it is listed in the error column of the mailbox browser.
If this is a clean install, there could be an issue where the list of mailboxes does not populate and includes one of the error messages listed below.
Error Message
The "Mailbox has no endpoint associated with it
" can have more specific error messages in the logs, such as:
Connecting to remote server failed with the following error message: The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubleshooting Help topic
.
OR
Connecting to remote server failed with the following error message : Access is denied. For more information, see the about_Remote_Troubleshooting Help topic.
Cause
Veritas is aware of 3 possible causes for this issue for Exchange on-premises.
Incorrect PowerShell and/or EWS URL
Incorrect login (Username or Password)
Failed SSL handshake when connecting to either PowerShell URL or EWS URL
In the case of O365 there is only 1 cause, Incorrect login (Username or Password)
Solution
First thing to check is that the correct URLs for both PowerShell and EWS are used, using the commands below from the Exchange Management Shell.
Get-PowershellVirtualDirectory | select InternalURL
Get-WebServicesVirtualDirectory | select InternalURL
In the case, there are multiple URLs for PowerShell , use the one that contains the FQDN of the server connecting to. If the FQDN is not listed as an internal URL, use the FQDN instead (http://fqdn.domain.com/powershell)
Next thing to check is the username and password for the Admin Account. Be sure to use either UPN (user@domain.com) or the pre-Windows 2000 format (domain\username). If there is a doubt of what the UPN is, please check the User properties on the Account tab to find the User logon name.
Lastly, for the PowerShell URL, in the case where the FQDN domain differs from the Internal URL gathered in the above step, it may be necessary to use an HTTP URL instead of HTTPS. Else, the certificate installed on that server will need to be updated to include both domain names.
At this point, choose to install a certificate with the correct domain name so that an HTTPS connection can be used. If it is chosen to keep the HTTP connection, be advised the following information will be gathered via PowerShell.
The PowerShell endpoint does the following:
1) When the task starts and during the initial sync, it establishes a connection, then calls Get-Mailbox to read all properties seen in the mailbox view. Basically, what is seen when a mailbox is processed.
2) When a mailbox is processed, the PowerShell endpoint will run a Get-Mailbox and return the following properties:
a) IsMailboxEnabled
b) IsInactiveMailbox
c) IsValid
d) IsSoftDeletedByDisable
e) IsSoftDeletedByRemove
f) IsShared