After upgrading to NetBackup 7.7.2 or 7.7.3, the "Configure Cloud Storage Server" wizard no longer displays a list of Cloud Providers

After upgrading to NetBackup 7.7.2 or 7.7.3, the "Configure Cloud Storage Server" wizard no longer displays a list of Cloud Providers

Article: 100032724
Last Published: 2020-04-01
Ratings: 0 0
Product(s): NetBackup

Problem

After upgrading to NetBackup 7.7.2 or 7.7.3, the "Configure Cloud Storage Server" wizard no longer displays a list of Cloud Providers. 

Instead, the following message appears:
User-added image

Could not receive response from NetBackup
CloudStore Service Container (nbcssc).
Refer to the nbcssc logs for more details.


Additionally, the command "csconfig cldprovider -l" returns the following error message:
Failed to fetch Cloud Providers.
Please see csconfig logs for more details

Cause

When the NetBackup CloudStore Service Container (nbcssc) daemon starts, it performs a sequence of checks to identify if the machine on which the nbcssc daemon is running is a Master Server or not.  If nbcssc determines it is NOT running on a Master Server, it initializes itself in 'client mode', and the following message is captured in the nbcssc log:

16/07/07 09:49:44 cssc : running in client mode!!


The check which performs this comparison was adjusted in 7.7.2, and is less tolerant to discrepancies (even if they are legitimate) between the physical hostname and the name of the local NetBackup instance.  As a consequence, if a legitimate discrepancy is found, nbcssc may choose to start in 'client mode'.



 

Solution

This issue exists in NetBackup 7.7.2 and NetBackup 7.7.3.

An Emergency Engineering Binary (EEB) containing a fix for this issue for NetBackup 7.7.2 and 7.7.3 is available by contacting Veritas technical support, referencing this document ID and the following Etracks.
  • 7.7.2 - Etrack 3879787
  • 7.7.3 - Etrack 3891726

If you think you have encountered this issue, please contact Veritas technical support

Veritas Technologies LLC is aware that the above-mentioned issue (Etracks 3879787, 3891726 ) is present in the current version(s) of the product(s) mentioned in this article. Veritas is committed to product quality and satisfied customers.  This issue was scheduled to be included in the following release:
  • NetBackup 8.0

When NetBackup 8.0 is available, please access the following link for download and README information:
 https://www.veritas.com/content/support/en_US/15143.html

Please note that Veritas reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability. Veritas' plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

References

Etrack : 3891726

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