NetBackup cloud service not working on NetBackup appliances

NetBackup cloud service not working on NetBackup appliances

  • Article ID:100031924
  • Last Published:
  • Product(s):Appliances

Problem

The NetBackup cloud service does not work, and users cannot configure cloud storage.
This issue may occur on NetBackup appliances with software versions 2.7.x, 3.0 and later. Review the following to determine whether you need the solution in this article:

NetBackup appliances with fresh installed software

  • 2.7.1, 2,7,2
Affected. The NetBackup cloud storage feature is not enabled. You need to perform the solution on both the master and media server appliances.
  • 2.7.3, 3.0
Not affected. The NetBackup cloud storage feature is enabled by default. However, it is recommended to perform the solution on the media server appliance to make sure the feature works well.
  • 3.1 and later
Affected. The NetBackup cloud storage feature is enabled on the master server appliance but not on the media server appliance. You need to perform the solution on the media server appliance to enable the NetBackup cloud storage feature.

NetBackup appliances with upgraded software

  • Upgraded to 2.7.1, 2.7,2
Affected. The NetBackup cloud storage feature is not enabled. You need to perform the solution on both the master and media server appliances.
  • Upgraded to 2.7.3, 3.0
Not affected. The NetBackup cloud storage feature is enabled by default. However, it is recommended to perform the solution on the media server appliance to make sure the feature works well.
  • Upgraded to 3.1 and later
Could be affected. It depends on the following conditions:
  • If the appliance was upgraded from 2.6.x, 2.7.1, 2.7.2, 2.7.3, and 3.0, the NetBackup cloud storage feature is automatically enabled after the upgrade. However, if the media server was offline when the master server appliance upgrade was ongoing, the feature cannot be enabled on the media server appliance. In this case, you need to perform the solution on the media server appliance to enable the feature.
  • If you have performed the solution on the appliances with version 2.7.1 or 2.7.2 before you upgrade the software to versions 3.1 and later, the NetBackup Cloud Storage feature remains enabled after the appliances are upgraded to 3.1 and later. You do not need to perform this solution again.

Error Message

N/A

Cause

  • The media server appliance could not get the hostname-based certificate from the associated master server.
  • The cloudstore.conf file on the appliance does not contain the NetBackup master server name.

Solution

To correct this problem, you must change the appliance host name in the cloudstore.conf file. For appliances that are configured as media servers, you must first provision a security certificate on the master server before you change the appliance host name in the cloudstore.conf file. Use the following procedures to make these changes to enable the NetBackup cloud storage feature.

To fix the issue on the master server appliance:

  1. Log in to the master server appliance as a NetBackupCLI user.
  2. Run the following command to check whether nbcssc is running in the background:
    bpps -x | grep nbcssc
  3. If the nbcssc service is running in the background, stop it by entering the following command:
    nbcssc -t
  4. Run the following command to add the host name to the cloudstore.conf file and start the nbcssc service:
    nbcssc -s -a NetBackup -f -m master_name

To fix the issue on the media server appliance:

  1. Log in to the master server appliance as a NetBackupCLI user.
  2. Run the following command to provision a certificate for the media server appliance where you want to enable the NetBackup cloud storage feature:
    bpnbaz -provisioncert media_server_name
  3. Log in to the media server appliance as a NetBackupCLI user.
  4. Run the following command from the media server to add the master server name to the cloudstore.conf file and start the nbcssc service:
    nbcssc -s -a NetBackup -f -m master_name

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