Archiving may stop on an FSA volume after restore from NetBackup

Archiving may stop on an FSA volume after restore from NetBackup

Article: 100031858
Last Published: 2016-01-29
Ratings: 2 0
Product(s): NetBackup

Problem

Archiving may stop on an Enterprise Vault FSA volume after it is restored from NetBackup with the following error message:

"Archiving point not found."

Cause

This issue is observed when the FSA volume is deleted and restored using NetBackup.
Folder creation time of restored volume gets modified by few nanoseconds, after the backup application restores a deleted folder which includes the EVArchivepoint.xml file.
This issue is seen in Enterprise Vault 10.0 and later using NetBackup 7.5 and later.
 

Solution

This issue is addressed in Enterprise Vault 11.0 and later by adding a configurable key in the config file ‘ Example EvFSAArchivingTask.exe.config to provide tolerance to the nanoseconds of time changed by NetBackup.

To override the changed folder creation time after a NetBackup restore, do the following:
  1. Open the directory C:\Program Files (x86)\Enterprise Vault and locate the config file Example EvFSAArchivingTask.exe.config .
  2. Edit this file and set ArchivePointFolderCreatedDateTolerance as required.
    <!-- Default: 0 nanoseconds. 1 unit = 100 nanoseconds. -->
    <add key="ArchivePointFolderCreatedDateTolerance" value = "0"/>
  3. Take a backup of EvFSAArchivingTask.exe.config (from directory C:\Program Files (x86)\Enterprise Vault).
  4. Rename the file ‘ Example EvFSAArchivingTask.exe.config to EvFSAArchivingTask.exe.config .
  5. Re-run the archiving task to start archiving on this volume.

References

Etrack : 2935364

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