AVVI (Agent for VMWare Virtual Infrastructure) backups fail with the error "0xe0009581 - Cannot get the virtual machine XML information"

Article: 100025735
Last Published: 2020-10-13
Ratings: 0 1
Product(s): Backup Exec

Problem

This Issue occurs when backup selections contains Virtual Machines selected from the VMware Vcenter server. If the Virtual machines are backed up directly from the ESX host then backups should complete successfully.

Error Message

Error #1

Found in the beremote.log on the media server.

[fsys\vmvcb] - SymVmTools: GetVmDetails: SYM_VMC_ERROR:  FAILED_TO_GET_MOB
[fsys\vmvcb] - SymVmTools: GetObjDetails: SYM_VMC_ERROR:  FAILED_TO_GET_VM_PROPERTIES
[fsys\vmvcb] - VM_VCBPROXY_FS::GetVmDetails: vmcGetObjDetails failed, result = 0X28
[fsys\vmvcb] - VM_VCBPROXY_FS::GeneratebackupTree() Status CODE (E0009543) Getting VM Details for '(DC)VM House(DC)\vm\VMName '
[fsys\vmvcb] - SymVmTools: RetrieveHostContents: Skipping host <ESXhost1.domain.local> because state is notResponding
[fsys\vmvcb] - SymVmTools: RetrieveHostContents: Skipping host <ESXhost2.domain.local> because state is notResponding
[fsys\vmvcb] - SymVmTools: SetVmPowerState: enableChangeTracking: Completed OK
[fsys\vmvcb] - VM_VCBPROXY_FS::GeneratebackupTree() VM () config file 'C:\Program Files\Symantec\Backup Exec\Data\config-b--22-06-2011-11-18.xml' is not found.

 

Error# 2

[fsys\shared]  - vddkConnectToVMWareServer() GD: status = 0X0

[fsys\shared]  - SymVmTools: GetVmPropertyInfo: SYM_VMC_ERROR:  SOAP_ERROR

[fsys\shared]  - vddkGetVmBackupInfo(): vmcGetVmBackupInfo() failed, result = 0X6

[ndmp\loops]  - LP_ENV::createVMWareSnapshot(): Failed to get config info for the VM '(DC) Datacenter(DC)\vm\HOSTNAME'

[fsys\shared]  - SymVmTools: httpsget: SYM_VMC_ERROR:  FAILED_TO_OPEN_FILE

[fsys\shared]  - vddkGetManagedObjInfo(): vddkGetManagedObjInfo() failed, result = 0X53

UMI: V-79-57344-38273
Error Code: 0xe0009581    Cannot get the virtual machine XML information.

Cause

This Issue may occur due to a Network Connection Timeout with the VCenter Server.

Solution

Solution #1

Create the "VCB refresh timeout" registry key on the media server and run the backups again.

Warning: Incorrect use of the Windows registry editor may prevent the operating system from functioning properly. Great care should be taken when making changes to a Windows registry. Registry modifications should only be carried-out by persons experienced in the use of the registry editor application. It is recommended that a complete backup of the registry and workstation be made prior to making any registry changes
 

  1. Open Registry Editor
  2. Go to the key HKLM\Software\Symantec\Backup Exec for Windows\Backup Exec\Engine\VMWare Agent\
  3. Create a new DWORD value "VCB refresh timeout"
  4. Set the "VCB refresh timeout" to decimal 6000.
  5. Restart Backup Exec Services.
  6. Run the backup job. 

Solution #2 

  1. Power Off the VM
  2. Right click and remove from inventory
  3. Browse the datastore for the VMX file for the VM
  4. Right Click and add to inventory

 

 

Was this content helpful?