Volume shrink operation changes a volume state to 'Healthy,RAW' and results in file system data corruption

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Problem

After performing the volume shrink operation, the volume state changes to ‘Healthy,RAW’ and the file system goes in to an unstable state and causes data corruption.

Cause

The volume shrink operation allows the size of dynamic volumes to be decreased. However, the current process of shrinking a volume does not handle all volume and file system scenarios that can arise in a Microsoft Windows environment.

When the volume shrink operation is started, it begins to move used blocks so as to accommodate them within the specified target shrink size for the volume.

However, this operation is not transactional. If there are any issues encountered during block moves or if the operation is halted for any reason (for example, the host reboots or shuts down, the operating system goes in to a hung state, or a stop error occurs, etc.), it can result in a file system corruption and cause data loss.

Solution

Veritas has identified the issue and is working on a fix to address the problem. Until the fix is available, Veritas strongly recommends to have a maintenance window where no new data will be written to the volume and a full back up copy of the data on the volume is created and verified before performing the volume shrink operation.

However, Veritas has created a hotfix that can be installed that will prompt a warning message each time a volume shrink operation is initiated. The message recommends that a back up and verification of the data on the target volume that is to be shrunk is performed before the volume shrink operation is performed. This hotfix, sfw-Hotfix_5_1_20024_87_2368399, can be downloaded from the Veritas Operations Readiness Tools (SORT) website using the URL https://sort.Veritas.com/patch/detail/5022.

The data can be backed up manually (either to a disk, tape, or other media) or using the SFW mirror operation to create an identical copy of the volume. If a maintenance windows cannot be obtained so new data is not written to the volume and a full back up and verification of the data cannot be performed for the volume shrink operation to be performed, it is strongly advised to not use the volume shrink operation at this time.

Note: If a volume shrink operation has been performed and the volume is in a Healthy, Raw state, the volume will need to be formatted and the data restored from the latest backup.

If a volume shrink operation is desired but has not been performed, Veritas recommends to back up and verify the data on the production volume and then mirror the volume to another disk during a maintenance period when there is no activity on the volume. At that time (when the volume is 100% synchronized), break the mirror to create a new volume and perform the shrink operation on it. If the volume shrink operation fails, leaving the volume status Healthy and the File system type Raw, since the original volume is left untouched, the production data can be quickly restored.

Please follow the below procedure to proceed with a volume shrink operation using a mirror copy of the volume:

  1. Mirror the volume that needs to be shrunk to another disk / LUN on the host. If a disk is not available, present more storage to the host that is equal to or greater than the disk that contains the volume. The procedure for adding a mirror to a volume can be found in the Veritas Storage Foundation 5.1 SP2 Administrator's Guide on page 258, https://sort.Veritas.com/public/documents/sfha/5.1sp2/windows/productguides/pdf/SFW_Admin_51SP2.pdf. The mirror process will be complete when the Console message in the Veritas Enterprise Administrator (VEA) reports "Resynchronization for \Device\HarddiskDmVolumes\<DG_NAME\<VOLUME_NAME> completed successfully.".
  2. During a maintenance window, after the mirror operation completes successfully, break the mirror following the procedure in the aforementioned guide beginning on page 260. When breaking the mirror, select the mirror copy with the disk / LUN that was added in step 1 above ensuring to create a uniquely identifiable volume label and assigning a temporary drive letter.
  3. Defragment the file system on the new volume.
  4. OPTIONAL: Perform a check disk on the file system of the new volume. Depending on the size of the volume, this could take a long period of time that could exceed the maintenance window.
  5. Perform the volume shrink operation on the new volume following the procedure in the aforementioned guide beginning on page 181.
  6. If the volume shrink operation is successful, remove the drive letter from the file system of both volumes and add the original production drive letter to the file system on the successfully shrunk volume following the procedure in the aforementioned guide beginning on page 167. The original, larger volume can now be removed.
  7. If the volume shrink operation fails, delete the volume and attempt the process again starting with step 1 above.

If the volume shrink continues to fail after performing the above procedure, Veritas recommends to create a new volume with the desired size following the procedure in the aforementioned guide beginning on page 61. During a maintenance window, perform a full backup of the production volume and then restore it to the new volume. After ensuring the restore was successful, change the drive letters on the volumes following step 6 in the above procedure.


Applies To

Storage Foundation for Windows (SFW) and Storage Foundation and High Availability (SFW-HA) for Windows, versions 5.0, 5.0 RP1, 5.0 RP1a, 5.0 RP2, 5.1, 5.1 AP1, 5.1 SP1, 5.1 SP1 AP1, and 5.1 SP2

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