Attempting to synchronize the Journal Mailbox fails with an error 3188

Article: 100021305
Last Published: 2021-10-05
Ratings: 0 0
Product(s): Enterprise Vault

Problem

Event ID 3188 is recorded in the Enterprise Vault (EV) event log after attempting to synchronize an Exchange Journal Mailbox target.

Error Message

 The following events will occur in the EV event log:

Event Type: Error
Event Source: Enterprise Vault
Event Category: Agent Client Broker
Event ID: 3188
Description:
An error occurred performing a request to synchronize the mailbox /o=Exchangeorg/ou=Exchange Administrative Group/cn=Recipients/cn=JournalMBX
Error: This mailbox cannot be processed until the Exchange provisioning task has processed the corresponding user's details. Ensure that a provisioning group includes this user and run the provisioning task. To disable these warnings, set the 'HideMissingPolicyInfoErrors' registry value to 1. See the documentation for further details. Mailbox: Message store: [0x80040d1d]

V-437-3188

Event Type: Warning
Event Source: Enterprise Vault
Event Category: Agent Client Broker
Event ID: 3357
Description:
This mailbox cannot be processed until the Exchange provisioning task has processed the corresponding user's details. Ensure that a provisioning group includes this user and run the provisioning task. To disable these warnings, set the 'HideMissingPolicyInfoErrors' registry value to 1. See the documentation for further details.
Mailbox:  /o=Exchangeorg/ou=Exchange Administrative Group/cn=Recipients/cn=JournalMBX
Message store:

V-437-3357

A DTrace of the AgentClientBroker process will show the following:

EV:M CAgentExchSynch::CheckForLegacyMailboxDNReuse - Entry
EV:M CAgentExchSynch::CheckForLegacyMailboxDNReuse - Retrieving MAPI property "PR_CREATION_TIME" from Top Level Mailbox Folder
EV:M CAgentExchSynch::CheckForLegacyMailboxDNReuse - has been reused for a new Exchange user
EV:M HRXEX fn trace :|Source : .\AgentExchSynch.cpp (CAgentExchSynch::FindMatchingMbxEntries) [lines {2692,2697,2698,2705,2726,2731,2734}] built Feb 13 04:53:09 2009|Description: Call error 0x80040d1d
EV:M HRXEX fn trace :|Source : .\AgentExchSynch.cpp (CAgentExchSynch::GetExchangeMailboxEntry) [lines {2499,2506}] built Feb 13 04:53:09 2009|Description: Call error 0x80040d1d

 

Cause

This issue can be caused when the:

  1. Journal Mailbox is added as a Target in the Vault Administration Console after the mailbox is newly created but before the Global Address List is updated.
  2. Vault Service Account does not have permissions to the Exchange Store.
  3. PR_CREATION_TIME property of the hidden message contained in the Journal Mailbox is older than the 'LastModified' date that is recorded for the Journal Mailbox target in the ExchangeMailboxEntry table of the EnterpriseVaultDirectory database.

NOTE: In the first and second situation, the ExchangeMailboxEntry Table in SQL is populated with an incorrect entry for the Journal Mailbox and needs to be removed and re-created.  However, these are much rarer occurrences.

Solution

The most common cause of this issue can be fixed by updating the 'LastModified' date field that is in the ExchangeMailboxEntry table for the Journal Mailbox target to the current date and time.

Warning: This procedure involves making changes to the EnterpriseVaultDirectory SQL database and should be carried out by person(s) familiar with Microsoft SQL Server.  Please ensure that a valid FULL backup of the EnterpriseVaultDirectory database exists prior to making these changes.

On the SQL Server:
Use SQL Query Analyzer (SQL 2000) or SQL Management Studio (2005 or above) to perform the following steps:

  1. Open the ExchangeMailboxEntry Table of the EnterpriseVaultDirectory Database
  2. With the ExchangeMailboxEntry Table open press Ctrl + 3 to open the SQL Query Pane
  3. Run the following SQL Query to find the inconsistent entries for the Journal Mailbox:

USE EnterpriseVaultDirectory
UPDATE ExchangeMailboxEntry
SET LastModified = GETDATE()
WHERE MbxDisplayName = 'Journal Mailbox Display Name'

On the Enterprise Vault Server:

  1. In the Vault Admin Console expand Enterprise Vault -> Directory on ServerName -> SiteName -> Enterprise Vault Servers -> Enterprise Vault Server Name -> Tasks
  2. Right-Click on the 'Exchange Journaling Task for ExchangeServerName' and select 'Properties'
  3. Select the Synchronization tab then click the Radio Button for 'Selected journal mailboxes'
  4. Press the 'Synchronize' button and Select the Journal Mailbox
  5. Click 'OK'
  6. A Pop-Up Message should now display:  The following mailboxes were synchronized listing the Journal Mailbox

If this did not resolve your issue please open a case with Veritas Support Services

 

 

Was this content helpful?