Problem
Backup of client failing with Status 58.
Error Message
(58) can't connect to client (58)
From job details:
02/12/2015 06:16:46 - Info bpbrm (pid=5198) connect failed STATUS (18) CONNECT_FAILED
02/12/2015 06:16:46 - Info bpbrm (pid=5198) status: FAILED, (42) CONNECT_REFUSED; system: (111) Connection refused; FROM 0.0.0.0 TO <CLIENT_NAME> <IP_ADDRESS> bpcd VIA pbx
02/12/2015 06:16:46 - Info bpbrm (pid=5198) status: FAILED, (42) CONNECT_REFUSED; system: (111) Connection refused; FROM 0.0.0.0 TO <CLIENT_NAME> <IP_ADDRESS> bpcd VIA vnetd
02/12/2015 06:16:46 - Info bpbrm (pid=5198) status: FAILED, (42) CONNECT_REFUSED; system: (111) Connection refused; FROM 0.0.0.0 TO <CLIENT_NAME> <IP_ADDRESS> bpcd
02/12/2015 06:16:46 - Error bpbrm (pid=5198) Cannot connect to <CLIENT_NAME>
02/12/2015 06:16:46 - Info bpbkar (pid=0) done. status: 58: can't connect to client
can't connect to client (58)
Cause
The NetBackup media server is unable to connect to the NetBackup client at the required ports.
The media server will attempt to connect to the client bpcd port via the following port numbers:
- 1556 (pbx)
- 13724 (vnetd)
- 13782 (bpcd)
The NetBackup media server will try connecting to the NetBackup client at each port above until it finds one that is open. If none of the ports are open the job will fail with Status 58.
Solution
Make sure the NetBackup media server is allowed access to the client at the following ports:
- 1556 (pbx)
- 13724 (vnetd)
- 13782 (bpcd)
To limit the number of open ports, 1556 is the only requirement. Ports 13724 and 13782 are attempted only when 1556 is not available.
For more information on NetBackup port requirements see the NetBackup firewall port requirements in the Related Articles documentation linked below.
Verify the client has it's local firewall software disabled or configured for port 1556 bi-directionally.